revert to previous behavior
authoragriffis <agriffis@gentoo.org>
Fri, 20 Feb 2004 17:12:18 +0000 (17:12 -0000)
committeragriffis <agriffis@gentoo.org>
Fri, 20 Feb 2004 17:12:18 +0000 (17:12 -0000)
svn path=/; revision=87

trunk/src/echangelog/ChangeLog
trunk/src/echangelog/echangelog

index 8639997a5be65c0e97c4d2c7cf03da452df4b769..72f706d23cf3fa5c0fc6a39a733d023ae32ce105 100644 (file)
@@ -1,3 +1,9 @@
+20 Feb 2004 Aron Griffis <agriffis@gentoo.org>
+       * Only update copyrights on modified ebuilds, otherwise if you run
+         echangelog again, it reports that all the ebuilds have been updated!
+         The copyright year issue would be better solved on Jan 1 of each year by
+         a separate script.
+
 17 Feb 2004 Aron Griffis <agriffis@gentoo.org>
        * Update copyrights on all ebuilds, not just the modified ones
 
index ca3684613fa9ef24da3aadf4c213bb9caefeff80..b8afe636f1edc4e75bcb63bcb308a56f0147426f 100644 (file)
@@ -184,10 +184,10 @@ print O $text            or die "Can't write ChangeLog.new: $!\n";
 close O                  or die "Can't close ChangeLog.new: $!\n";
 
 # Update affected ebuild copyright dates
-#for my $e (grep /\.ebuild$/, @files) {
+for my $e (grep /\.ebuild$/, @files) {
 # Update all ebuild copyright dates -- according to Mr_Bones_ this is
 # the right thing to do
-for my $e (<*.ebuild>) {
+#for my $e (<*.ebuild>) {
        my ($etext, $netext);
        open E, "<$e" or warn("Can't read $e to update copyright year\n"), next;
        { local $/ = undef; $etext = <E>; }