media-sound/qsynth-0.6.0: bump
authorMiroslav Šulc <fordfrog@gentoo.org>
Fri, 1 Nov 2019 12:15:43 +0000 (13:15 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Fri, 1 Nov 2019 12:15:43 +0000 (13:15 +0100)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-sound/qsynth/Manifest
media-sound/qsynth/qsynth-0.6.0.ebuild [new file with mode: 0644]

index c0b10ed01e5710a0dff1cee91fc886384801fd37..b1cc0d688517fe7856a508c8c22c82b92d0c6d42 100644 (file)
@@ -1 +1,2 @@
 DIST qsynth-0.5.6.tar.gz 269583 BLAKE2B 9b06f7be1aa39addebd0b088eff885bce39c6bc245461b64fe45243306afae8879d4b516bd46c30c2a8074e580e412c38a3c264d647a35ff5c81301703731067 SHA512 752b3ac7e478594ef873b2d1c9fcb1a1dcdd1fb33f34cab5f588f628d1f11f01ecd150c9d51021a41040794b68f0538ad6979751773d5c537f53a1f227b3bf88
+DIST qsynth-0.6.0.tar.gz 316308 BLAKE2B d414c73d5baf3be1563c45390735de964c79774a4d7cc37ff4bc609a7fa4d291a5b0cba7f3b8ed52649c50325a3ba2fba7baad3943122cc76a98aa6cfdf2cb0f SHA512 34e15d283f403ec6633fef911285dc2d4d4b2c5a0cd3614bd38feefbf68cff5fd8e296f47d1bcd527658b8a9dab212106aa63ca71ea60cf49f8126adb7d28591
diff --git a/media-sound/qsynth/qsynth-0.6.0.ebuild b/media-sound/qsynth/qsynth-0.6.0.ebuild
new file mode 100644 (file)
index 0000000..781890f
--- /dev/null
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop flag-o-matic qmake-utils xdg-utils
+
+DESCRIPTION="A Qt application to control FluidSynth"
+HOMEPAGE="http://qsynth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa debug jack pulseaudio"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+BDEPEND="
+       dev-qt/linguist-tools:5
+"
+DEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtwidgets:5
+       media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.4.0-qt5-tagging.patch" )
+
+src_configure() {
+       append-cxxflags -std=c++11
+       sed -e "/@gzip.*mandir)\/man1/d" -i Makefile.in || die
+       econf \
+               $(use_enable debug)
+
+       eqmake5 ${PN}.pro -o ${PN}.mak
+}
+
+src_install () {
+       emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+       einstalldocs
+
+       # The desktop file is invalid, and we also change the command
+       # depending on useflags
+       rm "${ED}/usr/share/applications/qsynth.desktop" || die
+
+       local cmd
+       if use jack; then
+               cmd="qsynth"
+       elif use pulseaudio; then
+               cmd="qsynth -a pulseaudio"
+       elif use alsa; then
+               cmd="qsynth -a alsa"
+       else
+               cmd="qsynth -a oss"
+       fi
+
+       make_desktop_entry "${cmd}" Qsynth qsynth
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}