mate-base/mate-panel: Bump to 1.22.2
authorAdam Feldman <NP-Hardass@gentoo.org>
Tue, 3 Mar 2020 22:18:46 +0000 (17:18 -0500)
committerAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 17:47:33 +0000 (13:47 -0400)
Package-Manager: Portage-2.3.82, Repoman-2.3.18
Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
mate-base/mate-panel/Manifest
mate-base/mate-panel/mate-panel-1.22.2.ebuild [new file with mode: 0644]

index 9be6b0688062164e36dd7b6549caa75cc7587fce..712dd4f9ac2209fc07e7ff600bd5fda0d43c6008 100644 (file)
@@ -1 +1,2 @@
 DIST mate-panel-1.22.1.tar.xz 2142620 BLAKE2B 3b105c04cd2c1bf0c5077fb79dc8f0fea090eca96b766567a3921c25d35f915d36446ad765fd226f2fc2a70d4c95987a1c503bd60a92210f944fb50a83bc6a90 SHA512 023599a2c0a879e32df11fc09d7526a54b8dc5248173c940e61df1dd9cbe8c04e4c916da89f5a64e44fe3f99462d56c72849314fc182c0af58a7c19e1fac642f
+DIST mate-panel-1.22.2.tar.xz 2216064 BLAKE2B c23d2c1efb52af3b5f1102ba4b9ac344d107f2836704809c3d843197940a1ae5cc7b025cfe07ead740107cf5004e304209641fd17a2559a140c7800eb63f793f SHA512 ccfd9e44116e66688d4de53c86e1a7d0754fd221b8083d7bee729f2a02a777a54b98ff70332b979aa075c157bc36c6ed6651f9190fa4a7e37b8a029a1f2a623f
diff --git a/mate-base/mate-panel/mate-panel-1.22.2.ebuild b/mate-base/mate-panel/mate-panel-1.22.2.ebuild
new file mode 100644 (file)
index 0000000..11413de
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The MATE panel"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X +introspection wayland"
+
+RDEPEND="
+       dev-libs/atk
+       >=dev-libs/dbus-glib-0.80:0
+       >=dev-libs/glib-2.50:2
+       >=dev-libs/libmateweather-1.17.0
+       dev-libs/libxml2:2
+       >=gnome-base/dconf-0.13.4
+       >=gnome-base/librsvg-2.36.2:2
+       >=mate-base/mate-desktop-1.17.0
+       >=mate-base/mate-menus-1.21.0
+       >=sys-apps/dbus-1.1.2
+       >=x11-libs/cairo-1
+       >=x11-libs/gdk-pixbuf-2.25.2:2
+       >=x11-libs/gtk+-3.22:3[introspection?]
+       x11-libs/libICE
+       x11-libs/libSM
+       >=x11-libs/libwnck-3.4.6:3[introspection?]
+       x11-libs/libX11
+       >=x11-libs/pango-1.15.4:0[introspection?]
+       x11-libs/libXau
+       >=x11-libs/libXrandr-1.3
+       virtual/libintl
+       introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+       wayland? ( dev-libs/wayland )"
+
+DEPEND="${RDEPEND}
+       app-text/docbook-xml-dtd:4.1.2
+       app-text/yelp-tools
+       >=dev-lang/perl-5:=
+       dev-util/glib-utils
+       dev-util/gdbus-codegen
+       dev-util/gtk-doc
+       dev-util/gtk-doc-am
+       >=dev-util/intltool-0.50.1
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+src_configure() {
+       mate_src_configure \
+               --libexecdir=/usr/libexec/mate-applets \
+               --disable-deprecation-flags \
+               $(use_enable X x11) \
+               $(use_enable introspection) \
+               $(use_enable wayland)
+}