old
authorMike Frysinger <vapier@gentoo.org>
Sun, 17 Dec 2006 01:01:50 +0000 (01:01 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sun, 17 Dec 2006 01:01:50 +0000 (01:01 +0000)
sys-devel/gcc/files/digest-gcc-4.3.0_alpha20061209 [deleted file]
sys-devel/gcc/gcc-4.3.0_alpha20061209.ebuild [deleted file]

diff --git a/sys-devel/gcc/files/digest-gcc-4.3.0_alpha20061209 b/sys-devel/gcc/files/digest-gcc-4.3.0_alpha20061209
deleted file mode 100644 (file)
index 5e92aa4..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 013625763694f2401761e1c1361359ed gcc-4.3-20061209.tar.bz2 41209354
-RMD160 cc3459d1672b0265a71c99673d1bb03b119b439a gcc-4.3-20061209.tar.bz2 41209354
-SHA256 35da3f52fb9c2a0a7e657c5209daea6b6f87d5c03a5cb44de67414a34d7fd338 gcc-4.3-20061209.tar.bz2 41209354
diff --git a/sys-devel/gcc/gcc-4.3.0_alpha20061209.ebuild b/sys-devel/gcc/gcc-4.3.0_alpha20061209.ebuild
deleted file mode 100644 (file)
index 3477437..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.0_alpha20061209.ebuild,v 1.2 2006/12/12 18:42:06 vapier Exp $
-
-ETYPE="gcc-compiler"
-
-inherit toolchain
-
-DESCRIPTION="The GNU Compiler Collection.  Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="-*"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
-       || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
-       virtual/libiconv
-       >=dev-libs/gmp-4.2.1
-       >=dev-libs/mpfr-2.2.0_p10
-       !build? (
-               gcj? (
-                       gtk? (
-                               || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
-                               >=x11-libs/gtk+-2.2
-                               x11-libs/pango
-                       )
-                       >=media-libs/libart_lgpl-2.1
-               )
-               >=sys-libs/ncurses-5.2-r2
-               nls? ( sys-devel/gettext )
-       )"
-DEPEND="${RDEPEND}
-       >=sys-apps/texinfo-4.2-r4
-       >=sys-devel/bison-1.875
-       >=${CATEGORY}/binutils-2.16.1"
-PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
-if [[ ${CATEGORY} != cross-* ]] ; then
-       PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
-fi
-
-pkg_setup() {
-       if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
-               die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild.  This is to try and cut down on people filing bugs for a compiler we do not currently support."
-       fi
-}
-
-src_unpack() {
-       gcc_src_unpack
-
-       use vanilla && return 0
-
-       # Fix cross-compiling
-       epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
-}
-
-pkg_postinst() {
-       toolchain_pkg_postinst
-
-       einfo "This gcc-4 ebuild is provided for your convenience, and the use"
-       einfo "of this compiler is not supported by the Gentoo Developers."
-       einfo "Please file bugs related to gcc-4 with upstream developers."
-       einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
-}