dev-python/boto3: add version 1.1.2
authorAlex Brandt <alunduil@gentoo.org>
Sat, 29 Aug 2015 23:37:45 +0000 (18:37 -0500)
committerAlex Brandt <alunduil@gentoo.org>
Sat, 29 Aug 2015 23:37:45 +0000 (18:37 -0500)
Package-Manager: portage-2.2.20.1

dev-python/boto3/Manifest
dev-python/boto3/boto3-1.1.2.ebuild [new file with mode: 0644]

index 49c32669716aad303843a0cd9ec36933311bedd0..146b92c08f729dda9b825a66c1b3639f95731a80 100644 (file)
@@ -1 +1,2 @@
 DIST boto3-1.1.1.tar.gz 137778 SHA256 02a99f270f58386dad6e260692b52f7038d52a9a84df29878528a573afecd88a SHA512 34019c8a3744775a952ae151b56747fc011fd4f28853e3d206f95bb8dd03746ad3d4086cd187d332930d543ca757d81bb732ccfd7cfd818aa8e75d73b1880be5 WHIRLPOOL 0032f5751df61bd71d60ea87ece0ce1be873a6fcd561d7600fcf62f1dd7b701963629368b46010b7a90719395adc652ca5059646af42510d72c05b7e3c5cf49e
+DIST boto3-1.1.2.tar.gz 141981 SHA256 6249add14f96b5e4cda0ac03798ab29f505c001332d2fb31ccb276e0ddcc5a15 SHA512 89b0abdab69dcd0c8ed612ecd70e5bdb88cc5242a3846fbdc5f708118d3f0db8c7eb5683422030eb630427dba53a5ea1780f5abbab58a021bf0bcacdeca07aef WHIRLPOOL c7c27d8c3c99ea992b2235beb60221c2899ea94557115b76366ce5922cef3606d9a2f907b0fdcce18e2eee1b19675849a354b50d429aa83ec1c364bf91a7ca5d
diff --git a/dev-python/boto3/boto3-1.1.2.ebuild b/dev-python/boto3/boto3-1.1.2.ebuild
new file mode 100644 (file)
index 0000000..2b98eeb
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="
+       >=dev-python/botocore-1.1.0[${PYTHON_USEDEP}]
+       <dev-python/botocore-1.2.0[${PYTHON_USEDEP}]
+       >=dev-python/jmespath-0.6.2[${PYTHON_USEDEP}]
+       <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '=dev-python/futures-2.2.0[${PYTHON_USEDEP}]' 'python2_7')
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? (
+               >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+               <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+               <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+       )
+       test? (
+               ${CDEPEND}
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       nosetests tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/build/html/. )
+
+       distutils-r1_python_install_all
+}