www-apache/mod_extract_forwarded: Replace underscore in flag name
authorMichał Górny <mgorny@gentoo.org>
Mon, 23 Sep 2019 07:44:17 +0000 (09:44 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 23 Sep 2019 08:07:12 +0000 (10:07 +0200)
Closes: https://bugs.gentoo.org/695156
Signed-off-by: Michał Górny <mgorny@gentoo.org>
www-apache/mod_extract_forwarded/metadata.xml
www-apache/mod_extract_forwarded/mod_extract_forwarded-2.0.3_pre2015052015.ebuild

index cd3828aea5dcd3efc11268621025754a1aec6d50..f30b35246ca73862373206def13b8b7267c919b9 100644 (file)
@@ -3,6 +3,6 @@
 <pkgmetadata>
 <!-- maintainer-needed -->
 <use>
-               <flag name="mod_proxy">Enable support for Apache's internal proxy</flag>
+               <flag name="mod-proxy">Enable support for Apache's internal proxy</flag>
        </use>
 </pkgmetadata>
index 284bedb2db25ed469015ac4d99ddadf227f344d9..24703f93f876f3134266539574f174a8a002a354 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -12,10 +12,10 @@ SRC_URI="https://dev.gentoo.org/~pacho/maintainer-needed/${P}.tar.xz"
 LICENSE="Apache-1.1"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE="mod_proxy"
+IUSE="mod-proxy"
 
 DEPEND=""
-RDEPEND="mod_proxy? ( www-servers/apache[apache2_modules_proxy_connect] )"
+RDEPEND="mod-proxy? ( www-servers/apache[apache2_modules_proxy_connect] )"
 
 APACHE2_MOD_CONF="98_${PN}"
 APACHE2_MOD_DEFINE="EXTRACT_FORWARDED"
@@ -23,7 +23,7 @@ APACHE2_MOD_DEFINE="EXTRACT_FORWARDED"
 need_apache2_4
 
 src_prepare() {
-       if ! use mod_proxy; then
+       if ! use mod-proxy; then
                sed -i -e 's:#define USING_proxy_http_module .*::' mod_extract_forwarded.c || die
        fi
 }