dev-python/pytest-asyncio: Bump to 0.11.0
authorMichał Górny <mgorny@gentoo.org>
Tue, 21 Apr 2020 06:11:08 +0000 (08:11 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 21 Apr 2020 08:08:06 +0000 (10:08 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-asyncio/Manifest
dev-python/pytest-asyncio/pytest-asyncio-0.11.0.ebuild [new file with mode: 0644]

index e74701959d85d2d471316ab874857c57ef86aa58..46a71b7ac0468c271622c75d0dc1a453640c5760 100644 (file)
@@ -1 +1,2 @@
 DIST pytest-asyncio-0.10.0.tar.gz 13968 BLAKE2B 4e63d527b20c767b8f0777ed684a15abe54009be72db8a50ca3b37ef95dceb884168d8081c651e2bbd6d818529d6809bb3498055fedc7f951f5675d58f50e408 SHA512 78160d1918c5d3d2172f74fa07bf4bf6d0bc416666011dd5b83b3a7f385ec30fc65d49c01bba5dd0e16ad9dcd9d72d8ab062526f3268d60cd2e24a35b5a8f883
+DIST pytest-asyncio-0.11.0.tar.gz 14070 BLAKE2B a97cc52a013e126c7aa48b21e8fdfb69c589efffefdfe0f1cef09ce98c1dd150f4298bfa9d707dfc264a6d48c71839847f929237204ba2a36e1bb1aae4e95cbe SHA512 db1d6a9c4b3f6f24014eacf3b108d76e5b2d6761d35260f20023638cd898b6f0b499dd475bc07abd58bc73bee2a88b565c3ebcced2460e619a1b375fa6a27a64
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.11.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.11.0.ebuild
new file mode 100644 (file)
index 0000000..25b4814
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+       https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+BDEPEND="
+       test? (
+               dev-python/async_generator[${PYTHON_USEDEP}]
+               >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+       )"
+
+distutils_enable_tests pytest
+
+python_test() {
+       distutils_install_for_testing
+       pytest -vv || die "Tests fail with ${EPYTHON}"
+}