patch added to support vdr-radio, vdr-lcr on glcd; fixed pkg_preinst call; thx to...
authorJoerg Bornkessel <hd_brummy@gentoo.org>
Mon, 27 Feb 2006 23:30:40 +0000 (23:30 +0000)
committerJoerg Bornkessel <hd_brummy@gentoo.org>
Mon, 27 Feb 2006 23:30:40 +0000 (23:30 +0000)
Package-Manager: portage-2.0.54

media-plugins/vdr-graphlcd/ChangeLog
media-plugins/vdr-graphlcd/Manifest
media-plugins/vdr-graphlcd/files/0.1.2/radiotext-lcr-service.diff [new file with mode: 0644]
media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.2_pre6-r1.ebuild

index c0b7207267a4e68d7de04339a00aafddfa00003c..fc9966b3e872af0235012d530666e173502a512b 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-plugins/vdr-graphlcd
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/ChangeLog,v 1.2 2006/01/09 21:11:44 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/ChangeLog,v 1.3 2006/02/27 23:30:40 hd_brummy Exp $
+
+  27 Feb 2006; Joerg Bornkessel <hd_brummy@gentoo.org>
+  +files/0.1.2/radiotext-lcr-service.diff,
+  vdr-graphlcd-0.1.2_pre6-r1.ebuild:
+  patch added to support vdr-radio, vdr-lcr on glcd; fixed pkg_preinst call;
+  thx to C.Leuschen for the patch
 
   09 Jan 2006; Joerg Bornkessel <hd_brummy@gentoo.org>
   vdr-graphlcd-0.1.2_pre6-r1.ebuild:
index 675dc35b44ece0e94a6554b81e467fd689b821d0..868805d5d3e360fc7a3bc575e92fd19d756f6bac 100644 (file)
@@ -1,6 +1,18 @@
-MD5 11164e4806dd81c423ca22c7e5c80d27 ChangeLog 622
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 c4cedd0d8a94003cbebde0145c6c6d19 ChangeLog 869
+MD5 1b06ba652dc14eb1a4884d49cdd4e3df files/0.1.2/radiotext-lcr-service.diff 3469
 MD5 b52e340ed185e77044523dcee028aae6 files/confd 681
 MD5 c06ef00216c435d94502bd44c0cf7e51 files/digest-vdr-graphlcd-0.1.2_pre6-r1 72
 MD5 517fd6e47ab25170f56df5a2a07510e6 files/rc-addon.sh 453
 MD5 363fe851c7edc1284983ea5393b8c2a9 metadata.xml 403
-MD5 cd0c4d0ac39438207b7ce5b4728998b7 vdr-graphlcd-0.1.2_pre6-r1.ebuild 2500
+MD5 824f70c028a55184036797fed05dfacd vdr-graphlcd-0.1.2_pre6-r1.ebuild 2528
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2.1 (GNU/Linux)
+Comment: no further Information
+
+iD8DBQFEA4uvdn07HTTCgIoRAsj8AJ4u4S/12yxrdF5LrxjlwnVfPqBPyACdGdTz
+3jObOOjrX5dNG7rap2bCXnw=
+=mAbn
+-----END PGP SIGNATURE-----
diff --git a/media-plugins/vdr-graphlcd/files/0.1.2/radiotext-lcr-service.diff b/media-plugins/vdr-graphlcd/files/0.1.2/radiotext-lcr-service.diff
new file mode 100644 (file)
index 0000000..45c7d46
--- /dev/null
@@ -0,0 +1,125 @@
+--- state.h.orig       2005-05-07 11:23:42.000000000 +0200
++++ state.h    2006-02-13 17:23:23.000000000 +0100
+@@ -120,4 +120,22 @@
+       tVolumeState GetVolumeState();
+ };
+
++// Radiotext
++struct RadioTextService_v1_0 {
++  int rds_info;
++  int rds_pty;
++  char *rds_text;
++  char *rds_title;
++  char *rds_artist;
++  struct tm *title_start;
++};
++
++// LcrData
++struct LcrService_v1_0 {
++  cString destination;
++  cString price;
++  cString pulse;
++};
++
+ #endif
++
+
+--- state.c.orig       2005-05-07 11:23:42.000000000 +0200
++++ state.c    2006-02-27 18:55:41.000000000 +0100
+@@ -15,6 +15,7 @@
+ #include "strfct.h"
+
+ #include <vdr/i18n.h>
++#include <vdr/plugin.h>
+
+ #include "compat.h"
+
+@@ -568,6 +569,8 @@
+
+ void cGraphLCDState::GetProgramme()
+ {
++    bool ptitle = false;
++
+       mutex.Lock();
+ #if VDRVERSNUM < 10300
+       const cEventInfo * present = NULL, * following = NULL;
+@@ -584,8 +587,10 @@
+                               {
+                                       event.presentTime = present->GetTime();
+                                       event.presentTitle = "";
+-                                      if (!isempty(present->GetTitle()))
++                                      if (!isempty(present->GetTitle())) {
+                                               event.presentTitle = present->GetTitle();
++                                              ptitle = true;
++                                              }
+                                       event.presentSubtitle = "";
+                                       if (!isempty(present->GetSubtitle()))
+                                               event.presentSubtitle = present->GetSubtitle();
+@@ -618,8 +623,10 @@
+                               {
+                                       event.presentTime = present->StartTime();
+                                       event.presentTitle = "";
+-                                      if (!isempty(present->Title()))
++                                      if (!isempty(present->Title())) {
+                                               event.presentTitle = present->Title();
++                                              ptitle = true;
++                                              }
+                                       event.presentSubtitle = "";
+                                       if (!isempty(present->ShortText()))
+                                               event.presentSubtitle = present->ShortText();
+@@ -639,6 +646,55 @@
+       }
+ #endif
+       mutex.Unlock();
++
++#if VDRVERSNUM >= 10330
++      { // get&display Radiotext
++              cPlugin *p;
++              p = cPluginManager::CallFirstService("RadioTextService-v1.0", NULL);
++              if (p) {
++                      RadioTextService_v1_0 rtext;
++                      if (cPluginManager::CallFirstService("RadioTextService-v1.0", &rtext)) {
++                              if (rtext.rds_info == 2 && strstr(rtext.rds_title, "---") == NULL) {
++                                      char rtpinfo[2][65], rtstr[140];
++                                      strcpy(rtpinfo[0], rtext.rds_title);
++                                      strcpy(rtpinfo[1], rtext.rds_artist);
++                                      sprintf(rtstr, "%02d:%02d  %s | %s", rtext.title_start->tm_hour, rtext.title_start->tm_min, trimright(rtpinfo[0]), trimright(rtpinfo[1]));
++                                      ptitle ? event.presentSubtitle = rtstr : event.presentTitle = rtstr;
++                              }
++                              else if (rtext.rds_info > 0) {
++                                      char rtstr[65];
++                                      strcpy(rtstr, rtext.rds_text);
++                                      ptitle ? event.presentSubtitle = trimright(rtstr) : event.presentTitle = trimright(rtstr);
++                              }
++                      }
++              }
++      }
++#endif
++
++
++#if VDRVERSNUM >= 10330
++      { // get&display LcrData
++              cPlugin *p;
++              p = cPluginManager::CallFirstService("LcrService-v1.0", NULL);
++              if (p)
++              {
++                      LcrService_v1_0 lcrData;
++                      if (cPluginManager::CallFirstService("LcrService-v1.0", &lcrData))
++                      {
++                              if ( strstr( lcrData.destination, "---" ) == NULL )
++                              {
++                                      char lcrStringParts[3][25], lcrString[100];
++                                      strcpy( lcrStringParts[0], (const char *)lcrData.destination );
++                                      strcpy( lcrStringParts[1], (const char *)lcrData.price );
++                                      strcpy( lcrStringParts[2], (const char *)lcrData.pulse );
++                                      sprintf(lcrString, "%s | %s", trimright(lcrStringParts[1]), trimright(lcrStringParts[2]));
++                                      event.presentTitle = trimright(lcrStringParts[0]);
++                                      event.presentSubtitle = trimright(lcrString);
++                              }
++                      }
++              }
++      }
++#endif
+ }
+
+ tChannelState cGraphLCDState::GetChannelState()
index 96f29e0aeff128170709f8d0db8491b01aa78eed..115bb5ec33d71e3fad5418c22650d2af36e65fba 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.2_pre6-r1.ebuild,v 1.2 2006/01/09 21:11:44 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.2_pre6-r1.ebuild,v 1.3 2006/02/27 23:30:40 hd_brummy Exp $
 
 inherit eutils vdr-plugin
 
@@ -25,6 +25,8 @@ DEPEND=">=media-video/vdr-1.2.6
 # DO NOT remove "!sys-apps/graphlcd-base" from DEPEND !!!
 # It will fix a conflict with ebuilds in Gentoo.de OVERLAY CVS
 
+PATCHES="${FILESDIR}/0.1.2/*"
+
 src_unpack() {
 
        vdr-plugin_src_unpack
@@ -38,7 +40,7 @@ src_install() {
 
        vdr-plugin_src_install
 
-       insopts -m0644 -ovdr -gvideo
+       insopts -m0644 -ovdr -gvdr
 
        insinto /usr/share/vdr/${VDRPLUGIN}/logos
        doins -r ${VDRPLUGIN}/logos/*
@@ -68,10 +70,10 @@ src_install() {
        fi
 }
 
-pkg_preinstall() {
+pkg_preinst() {
 
-       if [[ -e /etc/vdr/plugins/graphlcd/fonts ]] && [[ ! -L /etc/vdr/plugins/graphlcd/fonts ]] ||
-       [[ -e /etc/vdr/plugins/graphlcd/logos ]] && [[ ! -L /etc/vdr/plugins/graphlcd/logos ]] ;then
+       if [[ -e /etc/vdr/plugins/graphlcd/fonts ]] && [[ ! -L /etc/vdr/plugins/graphlcd/fonts ]] \
+       || [[ -e /etc/vdr/plugins/graphlcd/logos ]] && [[ ! -L /etc/vdr/plugins/graphlcd/logos ]] ;then
 
                einfo "Remove wrong DIR in /etc/vdr/plugins/graphlcd from prior install"
                einfo "Press CTRL+C to abbort"