dev-python/python-systemd: xfail test_notify_with_socket if bind() fails
authorMike Gilbert <floppym@gentoo.org>
Tue, 21 Feb 2017 23:58:44 +0000 (18:58 -0500)
committerMike Gilbert <floppym@gentoo.org>
Tue, 21 Feb 2017 23:59:16 +0000 (18:59 -0500)
Bug: https://bugs.gentoo.org/610368
Package-Manager: Portage-2.3.3_p56, Repoman-2.3.1_p49

dev-python/python-systemd/files/233-xfail-bind.patch [new file with mode: 0644]
dev-python/python-systemd/python-systemd-233.ebuild

diff --git a/dev-python/python-systemd/files/233-xfail-bind.patch b/dev-python/python-systemd/files/233-xfail-bind.patch
new file mode 100644 (file)
index 0000000..bb0fb76
--- /dev/null
@@ -0,0 +1,31 @@
+From 1c0d575f7c058f227d27b1cb92d3936d0c170a5f Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Tue, 21 Feb 2017 17:34:28 -0500
+Subject: [PATCH] test_daemon: xfail test_notify_with_socket if bind() fails
+
+This bind() call may fail if TMPDIR is too long.
+
+Bug: https://bugs.gentoo.org/610368
+---
+ systemd/test/test_daemon.py | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/systemd/test/test_daemon.py b/systemd/test/test_daemon.py
+index e827e1d..7733552 100644
+--- a/systemd/test/test_daemon.py
++++ b/systemd/test/test_daemon.py
+@@ -238,7 +238,10 @@ def test_notify_bad_socket():
+ def test_notify_with_socket(tmpdir):
+     path = tmpdir.join('socket').strpath
+     sock = socket.socket(socket.AF_UNIX, socket.SOCK_DGRAM)
+-    sock.bind(path)
++    try:
++        sock.bind(path)
++    except socket.error as e:
++        pytest.xfail('failed to bind socket (%s)' % e)
+     # SO_PASSCRED is not defined in python2.7
+     SO_PASSCRED = getattr(socket, 'SO_PASSCRED', 16)
+     sock.setsockopt(socket.SOL_SOCKET, SO_PASSCRED, 1)
+-- 
+2.11.1
+
index fbca17a286f2db02e7b4c6787555455a7a71ada7..3550384d778eeb07d4f949986aa03a21c0c68d3c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -26,6 +26,10 @@ RDEPEND="${COMMON_DEPEND}
        !sys-apps/systemd[python(-)]
 "
 
+PATCHES=(
+       "${FILESDIR}"/233-xfail-bind.patch
+)
+
 python_test() {
        pushd "${BUILD_DIR}/lib" > /dev/null || die
        "${EPYTHON}" -m pytest -v . || die