app-crypt/cardpeek: add libressl support
authorAnthony G. Basile <blueness@gentoo.org>
Fri, 3 Jun 2016 08:48:46 +0000 (04:48 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Fri, 3 Jun 2016 08:48:46 +0000 (04:48 -0400)
Package-Manager: portage-2.2.28

app-crypt/cardpeek/cardpeek-0.7.2.ebuild
app-crypt/cardpeek/cardpeek-0.8.4.ebuild

index f3ee99d21072cedddf8b96c55fd3e6dbba068890..c1482be5e715aa328675f22a7b365bc214aaf569 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -13,12 +13,14 @@ SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~amd64"
-IUSE=""
+IUSE="libressl"
 
 RDEPEND=">=x11-libs/gtk+-2.12:2
        sys-apps/pcsc-lite
        =dev-lang/lua-5.1*
-       dev-libs/openssl"
+       dev-libs/openssl
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )"
 
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
index 763e1b1685e604deeaf294a17b1b6d54779b61d2..116af8d7d14ae3ec8a634af191cdfed55f38f8ea 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -13,13 +13,14 @@ SRC_URI="http://downloads.pannetrat.com/install/${P}.tar.gz"
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS=""
-IUSE=""
+IUSE="libressl"
 
 RDEPEND="sys-apps/pcsc-lite
        dev-lang/lua:5.2
        x11-libs/gtk+:3
        net-misc/curl
-       dev-libs/openssl:*"
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )"
 
 DEPEND="${RDEPEND}
        virtual/pkgconfig"