games-fps/redeclipse: revision bump, fix installation
authorRob Levitsky <kitsunenokenja@protonmail.ch>
Sun, 28 Jan 2018 00:29:20 +0000 (19:29 -0500)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 1 Feb 2018 17:45:40 +0000 (18:45 +0100)
This revision fixes the incorrect installation of the desktop file
entry, and provides a wrapper script to address the runtime problem
introduced by no longer using EAPI 5's games installation paths.

Package-Manager: Portage-2.3.19, Repoman-2.3.6
Closes: https://github.com/gentoo/gentoo/pull/6979

games-fps/redeclipse/files/redeclipse [new file with mode: 0644]
games-fps/redeclipse/redeclipse-1.6.0-r1.ebuild [moved from games-fps/redeclipse/redeclipse-1.6.0.ebuild with 93% similarity]

diff --git a/games-fps/redeclipse/files/redeclipse b/games-fps/redeclipse/files/redeclipse
new file mode 100644 (file)
index 0000000..667765d
--- /dev/null
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+# It is necessary to run the binary from the root of the data directory
+# for the binary to properly locate its assets and load properly.
+# Upstream's original install procedure is doing the same thing.
+
+SERVER=/usr/bin/redeclipse_server_linux
+CLIENT=/usr/bin/redeclipse_linux
+cd /usr/share/redeclipse || exit 1
+[ "$0" = "redeclipse_server" ] && exec $SERVER || exec $CLIENT
similarity index 93%
rename from games-fps/redeclipse/redeclipse-1.6.0.ebuild
rename to games-fps/redeclipse/redeclipse-1.6.0-r1.ebuild
index 173ab9a6b751a75fb64c6bad09387d250b908054..5a45262fd901e5cca7f8223705fae23356cc0337 100644 (file)
@@ -70,10 +70,14 @@ src_install() {
        if ! use dedicated; then
                dobin src/redeclipse_linux
                newicon "src/install/nix/${PN}_x128.png" "${PN}.png"
-               make_desktop_entry "src/install/nix/${PN}.desktop"
+               domenu "src/install/nix/${PN}.desktop"
                doman doc/man/redeclipse.6
        fi
 
+       dobin "${FILESDIR}/redeclipse"
+       cd /usr/bin || die
+       dosym redeclipse redeclipse_server
+
        doman doc/man/redeclipse-server.6
        dodoc readme.txt doc/examples/servinit.cfg
 }