arm/ia64/s390/sh stable
authorMike Frysinger <vapier@gentoo.org>
Sat, 17 Feb 2007 15:13:16 +0000 (15:13 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 17 Feb 2007 15:13:16 +0000 (15:13 +0000)
Package-Manager: portage-2.1.2-r9

app-emacs/pymacs/pymacs-0.22-r1.ebuild
app-emacs/python-mode/python-mode-1.0.ebuild

index 63483ebd728fa3753fce0b110286307445ba9bdd..cf48c1e95972d8c9f08f62deee1673a52fcbb618 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/pymacs-0.22-r1.ebuild,v 1.5 2007/02/11 10:46:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/pymacs-0.22-r1.ebuild,v 1.6 2007/02/17 15:12:47 vapier Exp $
 
 inherit distutils elisp eutils
 
@@ -10,7 +10,7 @@ SRC_URI="http://pymacs.progiciels-bpi.ca/archives/${P/pymacs/Pymacs}.tar.gz"
 
 LICENSE="as-is"
 SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ppc ppc-macos ~s390 ~sh x86"
+KEYWORDS="~amd64 arm ia64 ppc ppc-macos s390 sh x86"
 IUSE="doc"
 
 DEPEND="virtual/emacs
@@ -20,7 +20,7 @@ S=${WORKDIR}/Pymacs-${PV}
 
 src_unpack() {
        unpack ${A}
-       epatch ${FILESDIR}/${PV}-character-encoding-gentoo.patch
+       epatch "${FILESDIR}"/${PV}-character-encoding-gentoo.patch
 }
 
 src_compile() {
@@ -30,12 +30,12 @@ src_compile() {
 
 src_install() {
        elisp-install ${PN} pymacs.el pymacs.elc
-       elisp-site-file-install ${FILESDIR}/50pymacs-gentoo.el
+       elisp-site-file-install "${FILESDIR}"/50pymacs-gentoo.el
        distutils_src_install
        if use doc ; then
                insinto /usr/share/doc/${PF}
                doins ./pymacs.pdf
        fi
-       cd ${S}
+       cd "${S}"
        dodoc PKG-INFO README THANKS TODO THANKS-rebox ChangeLog ChangeLog-rebox
 }
index 818ae98620760f289b4dcd9091f9d61d75464ee2..a9b44166c23aef9f48ee20e655cde225512ab337 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-1.0.ebuild,v 1.6 2007/02/11 10:46:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-1.0.ebuild,v 1.7 2007/02/17 15:13:16 vapier Exp $
 
 inherit elisp distutils
 
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
 
 LICENSE="as-is"
 SLOT="0"
-KEYWORDS="amd64 ~arm ~ia64 ppc ppc-macos ~s390 ~sh x86"
+KEYWORDS="amd64 arm ia64 ppc ppc-macos s390 sh x86"
 IUSE=""
 
 DEPEND="app-emacs/pymacs"
@@ -19,7 +19,7 @@ SITEFILE="60python-mode-gentoo.el"
 
 src_unpack() {
        unpack ${A}
-       cp ${FILESDIR}/setup.py ${S}
+       cp "${FILESDIR}"/setup.py ${S}
 }
 
 src_compile() {
@@ -30,7 +30,7 @@ src_compile() {
 src_install() {
        distutils_src_install
        elisp-install python-mode *.{el,elc}
-       elisp-site-file-install ${FILESDIR}/${SITEFILE}
+       elisp-site-file-install "${FILESDIR}"/${SITEFILE}
 }
 
 pkg_postinst() {