net-im/kadu: support newer CMake
authorMaciej Mrozowski <reavertm@gentoo.org>
Fri, 22 Nov 2019 01:11:07 +0000 (02:11 +0100)
committerMaciej Mrozowski <reavertm@gentoo.org>
Fri, 22 Nov 2019 01:15:59 +0000 (02:15 +0100)
Bug: https://bugs.gentoo.org/692232
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Maciej Mrozowski <reavertm@gentoo.org>
net-im/kadu/files/kadu-4.3-find-x11-with-newer-cmake-modules.patch [new file with mode: 0644]
net-im/kadu/kadu-4.3-r2.ebuild

diff --git a/net-im/kadu/files/kadu-4.3-find-x11-with-newer-cmake-modules.patch b/net-im/kadu/files/kadu-4.3-find-x11-with-newer-cmake-modules.patch
new file mode 100644 (file)
index 0000000..ec44a0b
--- /dev/null
@@ -0,0 +1,48 @@
+diff -ruN kadu-4.3/kadu-core/CMakeLists.txt my/kadu-core/CMakeLists.txt
+--- kadu-4.3/kadu-core/CMakeLists.txt  2017-01-24 22:36:21.000000000 +0100
++++ my/kadu-core/CMakeLists.txt        2019-11-22 02:05:51.381540018 +0100
+@@ -111,7 +111,7 @@
+ list (APPEND ADDITIONAL_LIBKADU_LIBRARIES ${LibArchive_LIBRARIES})
+ if (UNIX AND NOT APPLE)
+-      find_package (X11 REQUIRED COMPONENTS X11 Xutil Xfixes)
++      find_package (X11 REQUIRED COMPONENTS Xutil Xfixes)
+       if (X11_FOUND AND X11_Xutil_FOUND AND X11_Xfixes_FOUND)
+               message (STATUS "Found required X11 libraries: ${X11_X11_LIB};${X11_Xfixes_LIB}")
+       else ()
+diff -ruN kadu-4.3/plugins/idle/CMakeLists.txt my/plugins/idle/CMakeLists.txt
+--- kadu-4.3/plugins/idle/CMakeLists.txt       2017-01-24 22:36:22.000000000 +0100
++++ my/plugins/idle/CMakeLists.txt     2019-11-22 02:06:57.503381610 +0100
+@@ -15,7 +15,7 @@
+ )
+ if (UNIX AND NOT APPLE)
+-      find_package (X11 REQUIRED COMPONENTS X11 Xutil Xscreensaver)
++      find_package (X11 REQUIRED COMPONENTS Xutil Xscreensaver)
+       if (X11_Xscreensaver_FOUND)
+               message (STATUS "Found required X11 libraries: ${X11_X11_LIB};${X11_Xscreensaver_LIB}")
+       else ()
+diff -ruN kadu-4.3/plugins/pcspeaker/CMakeLists.txt my/plugins/pcspeaker/CMakeLists.txt
+--- kadu-4.3/plugins/pcspeaker/CMakeLists.txt  2017-01-24 22:36:22.000000000 +0100
++++ my/plugins/pcspeaker/CMakeLists.txt        2019-11-22 02:07:45.315719788 +0100
+@@ -15,7 +15,7 @@
+ set (LIBRARIES "")
+ if (UNIX AND NOT APPLE)
+-      find_package (X11 REQUIRED COMPONENTS X11)
++      find_package (X11 REQUIRED)
+       if (NOT X11_FOUND)
+               message (SEND_ERROR "Could NOT find X11")
+       endif ()
+diff -ruN kadu-4.3/plugins/screenshot/CMakeLists.txt my/plugins/screenshot/CMakeLists.txt
+--- kadu-4.3/plugins/screenshot/CMakeLists.txt 2017-01-24 22:36:22.000000000 +0100
++++ my/plugins/screenshot/CMakeLists.txt       2019-11-22 02:07:54.323972436 +0100
+@@ -30,7 +30,7 @@
+ if (UNIX AND NOT APPLE)
+       set (PLUGIN_ADDITIONAL_QT_MODULES X11Extras)
+-      find_package (X11 REQUIRED COMPONENTS X11 Xext Xshape)
++      find_package (X11 REQUIRED COMPONENTS Xext Xshape)
+       if (X11_Xshape_FOUND)
+               message (STATUS "Found required X11 libraries: ${X11_X11_LIB};${X11_Xext_LIB}")
+       else ()
index 10dd889fae2e41578c15ecea67c78899c471e1f9..8caf2eac7c4ffdc255d0de1bb639e90ea7719fb8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -40,6 +40,7 @@ COMMON_DEPEND="
        dev-qt/qtxml:5
        dev-qt/qtxmlpatterns:5
        x11-libs/libX11
+       x11-libs/libXfixes
        x11-libs/libXext
        x11-libs/libXScrnSaver
        gadu? ( >=net-libs/libgadu-1.12.2[threads] )
@@ -50,7 +51,7 @@ COMMON_DEPEND="
        )
        spell? ( app-text/enchant )
        xmpp? (
-               net-dns/libidn
+               net-dns/libidn:*
                >=net-libs/qxmpp-0.9.3-r1
                sys-libs/zlib
        )
@@ -102,6 +103,7 @@ PATCHES=(
        "${FILESDIR}/${PN}-4.3-do-not-force-ccache.patch"
        "${FILESDIR}/${PN}-4.3-fix-plugins-rpath.patch"
        "${FILESDIR}/${PN}-4.3-gcc7.patch"
+       "${FILESDIR}/${PN}-4.3-find-x11-with-newer-cmake-modules.patch"
 )
 
 src_configure() {