dev-php/pecl-stomp: Fix typo for bug 688308; update USE_PHP values
authorBrian Evans <grknight@gentoo.org>
Tue, 18 Jun 2019 19:27:48 +0000 (15:27 -0400)
committerBrian Evans <grknight@gentoo.org>
Tue, 18 Jun 2019 19:27:48 +0000 (15:27 -0400)
Closes: https://bugs.gentoo.org/688308
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Brian Evans <grknight@gentoo.org>
dev-php/pecl-stomp/pecl-stomp-1.0.9-r1.ebuild
dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild

index 8349a99f9a6c324563b0a8650812964ac9550bca..d8aef480451ffba99abd54e26c676304be60c556 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-USE_PHP="php5-6 php7-0"
+USE_PHP="php5-6 php7-1 php7-2 php7-3"
 PHP_EXT_NAME="stomp"
 DOCS=( CREDITS doc/classes.php doc/functions.php )
 
@@ -23,7 +23,11 @@ DEPEND="${DEPEND}
 "
 
 RDEPEND="${DEPEND}"
-PDEPEND="php_targets_php7-0? ( dev-php/pecl-stomp:7 )"
+PDEPEND="
+       php_targets_php7-1? ( dev-php/pecl-stomp:7 )
+       php_targets_php7-2? ( dev-php/pecl-stomp:7 )
+       php_targets_php7-3? ( dev-php/pecl-stomp:7 )
+"
 
 src_prepare() {
        if use php_targets_php5-6 ; then
index a4649795c926001b579ea26bc8917a95d9ca109e..d808c2c1b91795481d787fc6fc9581a403e1ae3e 100644 (file)
@@ -1,15 +1,15 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
+USE_PHP="php5-6 php7-1 php7-2 php7-3"
 PHP_EXT_NAME="stomp"
 DOCS=( CREDITS doc/classes.php doc/functions.php )
 
 inherit php-ext-pecl-r3
 
-USE_PHP="php7-0 php7-1 php7-2 php7-3"
+USE_PHP="php7-1 php7-2 php7-3"
 
 KEYWORDS="~amd64 ~x86"
 
@@ -19,7 +19,6 @@ SLOT="7"
 IUSE="examples ssl test"
 
 DEPEND="${DEPEND}
-       php_targets_php7-0? ( dev-lang/php:7.0[ssl?] )
        php_targets_php7-1? ( dev-lang/php:7.1[ssl?] )
        php_targets_php7-2? ( dev-lang/php:7.2[ssl?] )
        php_targets_php7-3? ( dev-lang/php:7.3[ssl?] )
@@ -29,7 +28,7 @@ RDEPEND="${DEPEND}
        php_targets_php5-6? ( dev-php/pecl-stomp:0 )"
 
 src_prepare() {
-       if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
                php-ext-source-r3_src_prepare
        else
                default
@@ -37,7 +36,7 @@ src_prepare() {
 }
 
 src_configure() {
-       if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7_2 || use php_targets_php7-3 ; then
+       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
                local PHP_EXT_ECONF_ARGS=(
                        --enable-stomp
                        --with-openssl-dir=$(usex ssl "${EPREFIX}/usr")
@@ -47,7 +46,7 @@ src_configure() {
 }
 
 src_install() {
-       if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7_2 || use php_targets_php7-3 ; then
+       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
                php-ext-pecl-r3_src_install
        fi
 }