x11-libs/wxGTK: update patchset, ignore C++ ABI changes at startup
authorMart Raudsepp <leio@gentoo.org>
Sun, 14 Jul 2019 10:44:39 +0000 (13:44 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 14 Jul 2019 11:09:19 +0000 (14:09 +0300)
Closes: https://bugs.gentoo.org/676878
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
x11-libs/wxGTK/Manifest
x11-libs/wxGTK/files/wxGTK-ignore-c++-abi.patch [new file with mode: 0644]
x11-libs/wxGTK/wxGTK-3.0.4-r2.ebuild [new file with mode: 0644]
x11-libs/wxGTK/wxGTK-3.0.4-r302.ebuild [new file with mode: 0644]

index 2ba51aec12d17551fdce82af361fb4f3f2a72a21..e98af7ed8c6ddef2177b55975fc3373dadb070a9 100644 (file)
@@ -1,6 +1,7 @@
 DIST wxGTK-3.0.3_p20180104.tar.xz 84260 BLAKE2B 3840a4a202778b3e7df0c3470945dd8f083b1b18aa69013ae59975b368cec4f5e9fea3bdd8a05a200fcd146c8616d2258f0b2ee389a6457a638201a8534f9a18 SHA512 840c8248d5a689a462d1dcb9d9962dd453473597d10289802728218a881808f594ff799d2002ceb319d2e79b1b7063d59b181d4a0efff7920a2dee9653b40a72
 DIST wxGTK-3.0.4_p20180507.tar.xz 2972 BLAKE2B 431855d43aefac6227925195c107b21f7539ca2709c98f6d6beb7d25dbdf8633c61bb160fb4e5c993e97dbddc37cdf90dc7b09753a312c25b16f79f0207cfe98 SHA512 9caa7ca3b6f15fd70014ccd4008c4fa76f12cb07d3fc58a8f0d2b9a591cf8be3f0eb40497dc757b9d0a04d26f54296aaa8fe693aa601bb1c058365529bb4bc8b
 DIST wxGTK-3.0.4_p20181106.tar.xz 28448 BLAKE2B dbbaaa49cbf03b42089c04d3c6045734f045e5bddc66b72f367f2ba1deed0531280c3bf3db873bf78dd33cee9873e20839ab38b94f90830b48bc1a8122164d02 SHA512 d1bde53b4eac1f8e6785379f99d585c926fd132c709ca134d7c8c3d62a2bcf77059b90f25333aa692932888318dadf464620b0a136341217cae7a2cd2c93ab50
+DIST wxGTK-3.0.4_p20190713.tar.xz 53640 BLAKE2B 89eabc44660f8f9b19fc850717eb83244a746f2f8c28bcec89fa9ccd1828f103df114bce24406ff14875220de86276f9e51870d58e716f0c94d310707f7eae4c SHA512 44a4e92ccc9c143a0e70e015116e952b0529001a3a1e23193d501826720a505259ead6feaa08de75b4a7a8753f8b16f5cc14e4bff5d15585870066ccd1de53b9
 DIST wxWidgets-3.0.3-docs-html.tar.bz2 23803675 BLAKE2B 181305a2b8935adee8d50873665bc094f46a061fe1bcf8521f8a4d5613013d6ad58ce172e56118f3833ce3489ab2e919bbd5482445ce55455e696252bb747d3c SHA512 655efde42e467d1d48d8adb95e2394d90cedca8eb6a54a7d53771d3d2d4d5f72637aea6ea12a4c1f570c3905a458aebea067cd74e184c4c85ca73e49e04282cb
 DIST wxWidgets-3.0.3.tar.bz2 20054446 BLAKE2B ebbe977a59f215fb2e35300aec91ad6d042d099586c4f6624d817c689feae090ff6df5718baa94a79e8e46120a6b4a154a7e9a584e14363e832602841502f0f6 SHA512 dfe53682d7cda1d460f336a890603c4e823078be4b05e7cf43ab36cb49247f702808aa939d9311705bdf5f96eaa076e7a8f77f4415bc07c5bfdc19e5deff1dd1
 DIST wxWidgets-3.0.4-docs-html.tar.bz2 24122986 BLAKE2B ffd38d50e6cb44077f346597863a8dfb1cb5172b9380995082acb23b5b5dae060bc1e3d14307a1146ccd93b5ae9c4fd8fb206346c8d5aced5a535cd3d7f8961a SHA512 2b4cefc98f5f034a8c36237c4979bd02e8b0ed60aaeb31946d8661fb8e5297172cec807e45c96fe2939b012f093950721cda8bf9f750697b50e3741711011ccd
diff --git a/x11-libs/wxGTK/files/wxGTK-ignore-c++-abi.patch b/x11-libs/wxGTK/files/wxGTK-ignore-c++-abi.patch
new file mode 100644 (file)
index 0000000..30026eb
--- /dev/null
@@ -0,0 +1,39 @@
+Description: Suppress error about mismatching C++ ABI version
+ In practice, the differences between recent ABI versions don't seem to be
+ incompatible since they apparently only affect obscure corner cases.  So
+ suppress this error so we don't have to rebuild the entire wx world in one
+ go.
+Author: Olly Betts <olly@survex.com>
+Forwarded: no
+Last-Update: 2017-07-26
+From: https://salsa.debian.org/freewx-team/wx/blob/wx3.0-debian/debian/patches/warn-for-compiler-abi-mismatch.patch
+
+--- a/src/common/appbase.cpp
++++ b/src/common/appbase.cpp
+@@ -762,6 +762,26 @@
+         msg.Printf(wxT("Mismatch between the program and library build versions detected.\nThe library used %s,\nand %s used %s."),
+                    lib.c_str(), progName.c_str(), prog.c_str());
++      int l_off = lib.Find("compiler with C++ ABI ");
++      int p_off = prog.Find("compiler with C++ ABI ");
++      if (l_off != wxNOT_FOUND && p_off != wxNOT_FOUND) {
++          int space;
++          space = lib.find(',', l_off + 22);
++          lib.erase(l_off, space - l_off);
++          space = prog.find(',', p_off + 22);
++          prog.erase(p_off, space - p_off);
++          if (lib == prog) {
++              // The only difference is the ABI version, which apparently only
++              // affect obscure cases.  We used to warn here, so at least
++              // there was an indication of what's up if there is a problem
++              // due to ABI incompatibilities, but wxLogWarning() can result
++              // in a pop up dialog with some applications, which is just too
++              // intrusive, so just quietly ignore instead.
++              //wxLogWarning(msg.c_str());
++              return false;
++          }
++      }
++
+         wxLogFatalError(msg.c_str());
+         // normally wxLogFatalError doesn't return
diff --git a/x11-libs/wxGTK/wxGTK-3.0.4-r2.ebuild b/x11-libs/wxGTK/wxGTK-3.0.4-r2.ebuild
new file mode 100644 (file)
index 0000000..006d41c
--- /dev/null
@@ -0,0 +1,141 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-minimal
+
+DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit"
+HOMEPAGE="https://wxwidgets.org/"
+SRC_URI="https://github.com/wxWidgets/wxWidgets/releases/download/v${PV}/wxWidgets-${PV}.tar.bz2
+       https://dev.gentoo.org/~leio/distfiles/wxGTK-3.0.4_p20190713.tar.xz
+       doc? ( https://github.com/wxWidgets/wxWidgets/releases/download/v${PV}/wxWidgets-${PV}-docs-html.tar.bz2 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+X aqua doc debug gstreamer libnotify opengl sdl tiff"
+
+SLOT="3.0"
+
+RDEPEND="
+       dev-libs/expat[${MULTILIB_USEDEP}]
+       sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+       X? (
+               >=dev-libs/glib-2.22:2[${MULTILIB_USEDEP}]
+               media-libs/libpng:0=[${MULTILIB_USEDEP}]
+               sys-libs/zlib[${MULTILIB_USEDEP}]
+               virtual/jpeg:0=[${MULTILIB_USEDEP}]
+               >=x11-libs/gtk+-2.18:2[${MULTILIB_USEDEP}]
+               x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}]
+               x11-libs/libSM[${MULTILIB_USEDEP}]
+               x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
+               x11-libs/pango[${MULTILIB_USEDEP}]
+               gstreamer? (
+                       media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
+                       media-libs/gst-plugins-base:1.0[${MULTILIB_USEDEP}] )
+               libnotify? ( x11-libs/libnotify[${MULTILIB_USEDEP}] )
+               opengl? ( virtual/opengl[${MULTILIB_USEDEP}] )
+               tiff?   ( media-libs/tiff:0[${MULTILIB_USEDEP}] )
+               )
+       aqua? (
+               x11-libs/gtk+:2[aqua=,${MULTILIB_USEDEP}]
+               virtual/jpeg:0=[${MULTILIB_USEDEP}]
+               tiff?   ( media-libs/tiff:0[${MULTILIB_USEDEP}] )
+               )"
+
+DEPEND="${RDEPEND}
+       virtual/pkgconfig[${MULTILIB_USEDEP}]
+       opengl? ( virtual/glu[${MULTILIB_USEDEP}] )
+       X? ( x11-base/xorg-proto )"
+
+PDEPEND=">=app-eselect/eselect-wxwidgets-20131230"
+
+LICENSE="wxWinLL-3 GPL-2 doc? ( wxWinFDL-3 )"
+
+S="${WORKDIR}/wxWidgets-${PV}"
+PATCHES=(
+       "${WORKDIR}"/wxGTK-3.0.4_p20190713/
+       "${FILESDIR}"/${PN}-3.0.5-collision.patch
+       "${FILESDIR}"/wxGTK-ignore-c++-abi.patch #676878
+)
+
+multilib_src_configure() {
+       local myconf
+
+       # X independent options
+       myconf="
+                       --with-zlib=sys
+                       --with-expat=sys
+                       --enable-compat28
+                       $(use_with sdl)"
+
+       # debug in >=2.9
+       # there is no longer separate debug libraries (gtk2ud)
+       # wxDEBUG_LEVEL=1 is the default and we will leave it enabled
+       # wxDEBUG_LEVEL=2 enables assertions that have expensive runtime costs.
+       # apps can disable these features by building w/ -NDEBUG or wxDEBUG_LEVEL_0.
+       # http://docs.wxwidgets.org/3.0/overview_debugging.html
+       # https://groups.google.com/group/wx-dev/browse_thread/thread/c3c7e78d63d7777f/05dee25410052d9c
+       use debug \
+               && myconf="${myconf} --enable-debug=max"
+
+       # wxGTK options
+       #   --enable-graphics_ctx - needed for webkit, editra
+       #   --without-gnomevfs - bug #203389
+       use X && \
+               myconf="${myconf}
+                       --enable-graphics_ctx
+                       --with-gtkprint
+                       --enable-gui
+                       --with-libpng=sys
+                       --with-libxpm=sys
+                       --with-libjpeg=sys
+                       --without-gnomevfs
+                       --disable-webview
+                       $(use_enable gstreamer mediactrl)
+                       $(use_with libnotify)
+                       $(use_with opengl)
+                       $(use_with tiff libtiff sys)"
+
+       use aqua && \
+               myconf="${myconf}
+                       --enable-graphics_ctx
+                       --enable-gui
+                       --with-libpng=sys
+                       --with-libxpm=sys
+                       --with-libjpeg=sys
+                       --with-mac
+                       --with-opengl"
+                       # cocoa toolkit seems to be broken
+
+       # wxBase options
+       if use !X && use !aqua ; then
+               myconf="${myconf}
+                       --disable-gui"
+       fi
+
+       ECONF_SOURCE="${S}" econf ${myconf}
+}
+
+multilib_src_install_all() {
+       cd "${S}"/docs || die
+       dodoc changes.txt readme.txt
+       newdoc base/readme.txt base_readme.txt
+       newdoc gtk/readme.txt gtk_readme.txt
+
+       use doc && HTML_DOCS="${WORKDIR}"/wxWidgets-${PV}-docs-html/.
+       einstalldocs
+
+       # Stray windows locale file, causes collisions
+       local wxmsw="${ED}usr/share/locale/it/LC_MESSAGES/wxmsw.mo"
+       [[ -e ${wxmsw} ]] && rm "${wxmsw}"
+}
+
+pkg_postinst() {
+       has_version app-eselect/eselect-wxwidgets \
+               && eselect wxwidgets update
+}
+
+pkg_postrm() {
+       has_version app-eselect/eselect-wxwidgets \
+               && eselect wxwidgets update
+}
diff --git a/x11-libs/wxGTK/wxGTK-3.0.4-r302.ebuild b/x11-libs/wxGTK/wxGTK-3.0.4-r302.ebuild
new file mode 100644 (file)
index 0000000..79ab9a6
--- /dev/null
@@ -0,0 +1,185 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-minimal
+
+DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit"
+HOMEPAGE="https://wxwidgets.org/"
+SRC_URI="https://github.com/wxWidgets/wxWidgets/releases/download/v${PV}/wxWidgets-${PV}.tar.bz2
+       https://dev.gentoo.org/~leio/distfiles/wxGTK-3.0.4_p20190713.tar.xz
+       doc? ( https://github.com/wxWidgets/wxWidgets/releases/download/v${PV}/wxWidgets-${PV}-docs-html.tar.bz2 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+X aqua doc debug gstreamer libnotify opengl sdl tiff webkit"
+
+WXSUBVERSION=${PV}.0-gtk3                      # 3.0.3.0-gtk3
+WXVERSION=${WXSUBVERSION%.*}                   # 3.0.3
+WXRELEASE=${WXVERSION%.*}-gtk3                 # 3.0-gtk3
+WXRELEASE_NODOT=${WXRELEASE//./}               # 30-gtk3
+
+SLOT="${WXRELEASE}"
+
+RDEPEND="
+       dev-libs/expat[${MULTILIB_USEDEP}]
+       sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+       X? (
+               >=dev-libs/glib-2.22:2[${MULTILIB_USEDEP}]
+               media-libs/libpng:0=[${MULTILIB_USEDEP}]
+               sys-libs/zlib[${MULTILIB_USEDEP}]
+               virtual/jpeg:0=[${MULTILIB_USEDEP}]
+               x11-libs/cairo[${MULTILIB_USEDEP}]
+               x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+               x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}]
+               x11-libs/libSM[${MULTILIB_USEDEP}]
+               x11-libs/libX11[${MULTILIB_USEDEP}]
+               x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
+               x11-libs/pango[${MULTILIB_USEDEP}]
+               gstreamer? (
+                       media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
+                       media-libs/gst-plugins-base:1.0[${MULTILIB_USEDEP}] )
+               libnotify? ( x11-libs/libnotify[${MULTILIB_USEDEP}] )
+               opengl? ( virtual/opengl[${MULTILIB_USEDEP}] )
+               tiff?   ( media-libs/tiff:0[${MULTILIB_USEDEP}] )
+               webkit? ( net-libs/webkit-gtk:4 )
+               )
+       aqua? (
+               x11-libs/gtk+:3[aqua=,${MULTILIB_USEDEP}]
+               virtual/jpeg:0=[${MULTILIB_USEDEP}]
+               tiff?   ( media-libs/tiff:0[${MULTILIB_USEDEP}] )
+               )"
+
+DEPEND="${RDEPEND}
+       virtual/pkgconfig[${MULTILIB_USEDEP}]
+       opengl? ( virtual/glu[${MULTILIB_USEDEP}] )
+       X? ( x11-base/xorg-proto )"
+
+PDEPEND=">=app-eselect/eselect-wxwidgets-20131230"
+
+LICENSE="wxWinLL-3 GPL-2 doc? ( wxWinFDL-3 )"
+
+S="${WORKDIR}/wxWidgets-${PV}"
+
+PATCHES=(
+       "${WORKDIR}"/wxGTK-3.0.4_p20190713/
+       "${FILESDIR}"/wxGTK-${SLOT}-translation-domain.patch
+       "${FILESDIR}"/wxGTK-ignore-c++-abi.patch #676878
+)
+
+src_prepare() {
+       default
+
+       # Versionating
+       sed -i \
+               -e "s:\(WX_RELEASE = \).*:\1${WXRELEASE}:"\
+               -e "s:\(WX_RELEASE_NODOT = \).*:\1${WXRELEASE_NODOT}:"\
+               -e "s:\(WX_VERSION = \).*:\1${WXVERSION}:"\
+               -e "s:aclocal):aclocal/wxwin${WXRELEASE_NODOT}.m4):" \
+               -e "s:wxstd.mo:wxstd${WXRELEASE_NODOT}.mo:" \
+               -e "s:wxmsw.mo:wxmsw${WXRELEASE_NODOT}.mo:" \
+               Makefile.in || die
+
+       sed -i \
+               -e "s:\(WX_RELEASE = \).*:\1${WXRELEASE}:"\
+               utils/wxrc/Makefile.in || die
+
+       sed -i \
+               -e "s:\(WX_VERSION=\).*:\1${WXVERSION}:" \
+               -e "s:\(WX_RELEASE=\).*:\1${WXRELEASE}:" \
+               -e "s:\(WX_SUBVERSION=\).*:\1${WXSUBVERSION}:" \
+               -e '/WX_VERSION_TAG=/ s:${WX_RELEASE}:3.0:' \
+               configure || die
+}
+
+multilib_src_configure() {
+       local myconf
+
+       # X independent options
+       myconf="
+                       --with-zlib=sys
+                       --with-expat=sys
+                       --enable-compat28
+                       $(use_with sdl)"
+
+       # debug in >=2.9
+       # there is no longer separate debug libraries (gtk2ud)
+       # wxDEBUG_LEVEL=1 is the default and we will leave it enabled
+       # wxDEBUG_LEVEL=2 enables assertions that have expensive runtime costs.
+       # apps can disable these features by building w/ -NDEBUG or wxDEBUG_LEVEL_0.
+       # http://docs.wxwidgets.org/3.0/overview_debugging.html
+       # https://groups.google.com/group/wx-dev/browse_thread/thread/c3c7e78d63d7777f/05dee25410052d9c
+       use debug \
+               && myconf="${myconf} --enable-debug=max"
+
+       # wxGTK options
+       #   --enable-graphics_ctx - needed for webkit, editra
+       #   --without-gnomevfs - bug #203389
+       use X && \
+               myconf="${myconf}
+                       --enable-graphics_ctx
+                       --with-gtkprint
+                       --enable-gui
+                       --with-gtk=3
+                       --with-libpng=sys
+                       --with-libjpeg=sys
+                       --without-gnomevfs
+                       $(use_enable gstreamer mediactrl)
+                       $(multilib_native_use_enable webkit webview)
+                       $(use_with libnotify)
+                       $(use_with opengl)
+                       $(use_with tiff libtiff sys)"
+
+       use aqua && \
+               myconf="${myconf}
+                       --enable-graphics_ctx
+                       --enable-gui
+                       --with-libpng=sys
+                       --with-libxpm=sys
+                       --with-libjpeg=sys
+                       --with-mac
+                       --with-opengl"
+                       # cocoa toolkit seems to be broken
+
+       # wxBase options
+       if use !X && use !aqua ; then
+               myconf="${myconf}
+                       --disable-gui"
+       fi
+
+       ECONF_SOURCE="${S}" econf ${myconf}
+}
+
+multilib_src_install_all() {
+       cd "${S}"/docs || die
+       dodoc changes.txt readme.txt
+       newdoc base/readme.txt base_readme.txt
+       newdoc gtk/readme.txt gtk_readme.txt
+
+       use doc && HTML_DOCS="${WORKDIR}"/wxWidgets-${PV}-docs-html/.
+       einstalldocs
+
+       # Stray windows locale file, bug #650118
+       local wxmsw="${ED}usr/share/locale/it/LC_MESSAGES/wxmsw30-gtk3.mo"
+       [[ -e ${wxmsw} ]] && rm "${wxmsw}"
+
+       # Unversioned links
+       rm "${D}"/usr/bin/wx{-config,rc}
+
+       # version bakefile presets
+       pushd "${D}"usr/share/bakefile/presets/ > /dev/null
+       for f in wx*; do
+               mv "${f}" "${f/wx/wx30gtk3}"
+       done
+       popd > /dev/null
+}
+
+pkg_postinst() {
+       has_version app-eselect/eselect-wxwidgets \
+               && eselect wxwidgets update
+}
+
+pkg_postrm() {
+       has_version app-eselect/eselect-wxwidgets \
+               && eselect wxwidgets update
+}