dev-python/toml: Version bump to 0.10.1
authorMatt Turner <mattst88@gentoo.org>
Wed, 20 May 2020 21:57:05 +0000 (14:57 -0700)
committerMatt Turner <mattst88@gentoo.org>
Wed, 20 May 2020 22:04:08 +0000 (15:04 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-python/toml/Manifest
dev-python/toml/toml-0.10.1.ebuild [new file with mode: 0644]

index 692ee569c924dbee8e52cdc8b48d0b5d972214e3..ab49645f677fdfa6cbaf8e3b7ed32dd61cf005fd 100644 (file)
@@ -1,2 +1,4 @@
 DIST toml-0.10.0-1.tar.gz 20396 BLAKE2B 3ddcb4cadfc68239cfcb34938a785b27326991ea89966aa6ba3ff2c8a430099664dce1474adf453f2d372b0d149c43584bce9c7abee4c8cbec3126adb3d2ab95 SHA512 ebad9d87606cf66f3db5abb2b0abd333d5536037446df131bda3f8138c33a6495a8923fc583328c27632d39448790e0e6788745d8acd7d600ea3ce57cb7dbd45
+DIST toml-0.10.1-1.tar.gz 22559 BLAKE2B 17d9d9c78f2b78a6fc5bc0efd8530af5514d2f965eb1896a0eaca9a6d8ce1dda3a5dc825a8b6cd2a2096a582bd35952e6f0a3372021c739c69186d5a2c5642be SHA512 0a2348bffc889e63f4c6f8ae4faf022cceff069b178d086a37ff03e97e0f24b4b5a72810a345692f21810f3f41908b6981da902862adb06286bdb2941e9e0d60
+DIST toml-test-280497fa5f12e43d7233aed0d74e07ca61ef176b.tar.gz 19593 BLAKE2B e9deba7c5d1eea7bd87fcf5e5c74bda4c2b9e9686e597e3ad51516f60eb8d192fb01d052ac57729c6f0851e2715cc6409a904affd637c9b099cabc1b12ad5d52 SHA512 7bd69b8c14f09bf431094b52d988eb233922527719ba5047ff769d2e709c2039fb6fb1c8144e630ad2a58835d19e0e4cc51433a427596d37f8eccb6d73d7e5c0
 DIST toml-test-39bb76d631ba103a94b377aaf52c979456677fb1.tar.gz 19304 BLAKE2B 5bb73ff91146ee85f6844132cdfc06673cdb384810c6c978cfc9f8ce6ba8b1607a0dc2d03aa868791d5fd33d00ebac96a4cd57a98948a3ef9318a52417904eda SHA512 931ba91b77da576979bde290c99f6cb1a2eeec3aee55b5041b0216094c584934d560487d329df21caa64b405ec50b4dd417dc910bbe4f15b1440686efc58da29
diff --git a/dev-python/toml/toml-0.10.1.ebuild b/dev-python/toml/toml-0.10.1.ebuild
new file mode 100644 (file)
index 0000000..2dc1660
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+
+inherit distutils-r1
+
+TOML_TEST_VER="280497fa5f12e43d7233aed0d74e07ca61ef176b"
+
+DESCRIPTION="Python library for handling TOML files"
+HOMEPAGE="https://github.com/uiri/toml"
+SRC_URI="https://github.com/uiri/${PN}/archive/${PV}.tar.gz -> ${P}-1.tar.gz
+       test? ( https://github.com/BurntSushi/toml-test/archive/${TOML_TEST_VER}.tar.gz -> toml-test-${TOML_TEST_VER}.tar.gz )"
+IUSE="test"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python3*') )"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+       if use test; then
+               mv "${WORKDIR}/toml-test-${TOML_TEST_VER#v}" "${S}/toml-test" || die
+       fi
+
+       distutils-r1_python_prepare_all
+}