dev-util/pkgcheck: Fix has_version statements
authorMichał Górny <mgorny@gentoo.org>
Thu, 5 Dec 2019 07:07:55 +0000 (08:07 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 5 Dec 2019 07:12:48 +0000 (08:12 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/pkgcheck/pkgcheck-0.7.1.ebuild
dev-util/pkgcheck/pkgcheck-9999.ebuild

index b812a50541dcc0276e3777971a82f621dcff479f..85632f39aa0fc49e3db89f3d94ef049daeb29f5a 100644 (file)
@@ -50,8 +50,8 @@ DEPEND="${RDEPEND}
 
 python_check_deps() {
        if use doc; then
-               has_version "dev-python/setuptools[${PYTHON_USEDEP}]"
-               has_version "dev-python/docutils[${PYTHON_USEDEP}]"
+               has_version "dev-python/setuptools[${PYTHON_USEDEP}]" &&
+               has_version "dev-python/docutils[${PYTHON_USEDEP}]" &&
                has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
        fi
 }
index b812a50541dcc0276e3777971a82f621dcff479f..85632f39aa0fc49e3db89f3d94ef049daeb29f5a 100644 (file)
@@ -50,8 +50,8 @@ DEPEND="${RDEPEND}
 
 python_check_deps() {
        if use doc; then
-               has_version "dev-python/setuptools[${PYTHON_USEDEP}]"
-               has_version "dev-python/docutils[${PYTHON_USEDEP}]"
+               has_version "dev-python/setuptools[${PYTHON_USEDEP}]" &&
+               has_version "dev-python/docutils[${PYTHON_USEDEP}]" &&
                has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
        fi
 }