net-wireless/blueman: Bump to 2.1.3
authorMichał Górny <mgorny@gentoo.org>
Wed, 13 May 2020 07:12:18 +0000 (09:12 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 13 May 2020 09:02:55 +0000 (11:02 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-wireless/blueman/Manifest
net-wireless/blueman/blueman-2.1.3.ebuild [new file with mode: 0644]

index 0f4401f9c1c8cf3bdd7b729512cddaccd7e4f79b..7cdcf743cc2e3fb1744b1c3c1fe6ee3e03e6f00a 100644 (file)
@@ -1 +1,2 @@
 DIST blueman-2.1.2.tar.xz 950296 BLAKE2B dec19174813a76d5abb941b7a93257428175961c4f05709e5c1ba304302b4163a61cde2ae5938f40053ea43298ee8ac483cd0439c80ce76bae41a95b3dc8d5ac SHA512 44d397d3a9d154d05b5231e18e624bf1ca33c690be5eeb448620ba4882110306925b78dbbbd815384ee3faeff147d2b042c01be28fb1b43568924c9657484527
+DIST blueman-2.1.3.tar.xz 950772 BLAKE2B bec7c8da59b94e8f30ff5f41e057ae5662928a4469b46d0ad2b33521a9b3a5de94056f6f35440d90e05116b1dd83dcd2437f1c00fb6b9532c14ab0698716c57a SHA512 376007c6e857f0e10a4d5e4bc2a50f6d170d393389d3aa5d02728646bf27e2fe5c08fb835bb5432a980d2b6c70c348a0274015552be6229c15a89c34c0d105f2
diff --git a/net-wireless/blueman/blueman-2.1.3.ebuild b/net-wireless/blueman/blueman-2.1.3.ebuild
new file mode 100644 (file)
index 0000000..8144b23
--- /dev/null
@@ -0,0 +1,132 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit autotools gnome2-utils linux-info python-single-r1 systemd xdg-utils
+
+DESCRIPTION="Simple and intuitive GTK+ Bluetooth Manager"
+HOMEPAGE="https://github.com/blueman-project/blueman"
+
+if [[ ${PV} == "9999" ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/blueman-project/blueman.git"
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/blueman-project/${PN}/releases/download/${PV/_/.}/${P/_/.}.tar.xz"
+       S=${WORKDIR}/${P/_/.}
+       KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+# icons are GPL-2
+# source files are mixed GPL-3+ and GPL-2+
+LICENSE="GPL-3+ GPL-2"
+SLOT="0"
+IUSE="appindicator network nls policykit pulseaudio"
+
+DEPEND="
+       $(python_gen_cond_dep '
+               dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+       ')
+       >=net-wireless/bluez-5:=
+       ${PYTHON_DEPS}"
+BDEPEND="
+       $(python_gen_cond_dep '
+               dev-python/cython[${PYTHON_MULTI_USEDEP}]
+       ')
+       virtual/pkgconfig
+       nls? ( dev-util/intltool sys-devel/gettext )"
+RDEPEND="${DEPEND}
+       $(python_gen_cond_dep '
+               dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+       ')
+       sys-apps/dbus
+       x11-libs/gtk+:3[introspection]
+       x11-libs/libnotify[introspection]
+       || (
+               x11-themes/adwaita-icon-theme
+               x11-themes/faenza-icon-theme
+               x11-themes/mate-icon-theme
+       )
+       appindicator? ( dev-libs/libappindicator:3[introspection] )
+       network? (
+               net-firewall/iptables
+               || (
+                       sys-apps/net-tools
+                       sys-apps/iproute2
+               )
+               || (
+                       net-dns/dnsmasq
+                       net-misc/dhcp
+                       >=net-misc/networkmanager-0.8
+               )
+       )
+       policykit? ( sys-auth/polkit )
+       pulseaudio? (
+               || (
+                       media-sound/pulseaudio[bluetooth]
+                       media-sound/pulseaudio-modules-bt
+               )
+       )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_pretend() {
+       if use network; then
+               local CONFIG_CHECK="~BRIDGE ~IP_NF_IPTABLES
+                       ~IP_NF_NAT ~IP_NF_TARGET_MASQUERADE"
+               check_extra_config
+       fi
+}
+
+pkg_setup() {
+       python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+       # replace py-compile to fix py3
+       [[ ${PV} == 9999 ]] && eautoreconf || eautomake
+}
+
+src_configure() {
+       local myconf=(
+               --disable-runtime-deps-check
+               --disable-static
+               --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+               --with-systemduserunitdir="$(systemd_get_userunitdir)"
+               --with-dhcp-config="/etc/dhcp/dhcpd.conf"
+               $(use_enable appindicator)
+               $(use_enable policykit polkit)
+               $(use_enable nls)
+               $(use_enable pulseaudio)
+               # thunar integration is a single data file with no extra deps
+               # so install it unconditionally
+               --enable-thunar-sendto
+       )
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+
+       if use policykit; then
+               # Allow users in plugdev group to modify connections
+               insinto /usr/share/polkit-1/rules.d
+               doins "${FILESDIR}/01-org.blueman.rules"
+       fi
+
+       rm "${D}"/$(python_get_sitedir)/*.la || die
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+       gnome2_schemas_update
+}