app-crypt/ssss: respect users ldflags
authorConrad Kostecki <conikost@gentoo.org>
Sun, 10 May 2020 14:38:11 +0000 (16:38 +0200)
committerConrad Kostecki <conikost@gentoo.org>
Sun, 10 May 2020 16:22:10 +0000 (18:22 +0200)
Closes: https://bugs.gentoo.org/722074
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
app-crypt/ssss/ssss-0.5-r1.ebuild [new file with mode: 0644]

diff --git a/app-crypt/ssss/ssss-0.5-r1.ebuild b/app-crypt/ssss/ssss-0.5-r1.ebuild
new file mode 100644 (file)
index 0000000..9941136
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Shamir's Secret Sharing Scheme"
+HOMEPAGE="http://point-at-infinity.org/ssss/"
+SRC_URI="http://point-at-infinity.org/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="dev-libs/gmp:0="
+DEPEND="${RDEPEND}"
+BDEPEND="app-doc/xmltoman"
+
+DOCS=( "HISTORY" "THANKS" )
+HTML_DOCS=( "doc.html" "ssss.1.html" )
+
+src_prepare() {
+       default
+
+       tc-export CC
+
+       # Respect users [CL]FLAGS and don't strip, as portage does this part
+       sed -e 's/-O2/$(CFLAGS) -lgmp $(LDFLAGS)/g' -e '/strip/d' -i Makefile || die
+}
+
+src_install() {
+       dobin ssss-split
+       dosym ssss-split /usr/bin/ssss-combine
+
+       doman ssss.1
+
+       einstalldocs
+}