Fix broken autotools handling.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 18:27:03 +0000 (18:27 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 18:27:03 +0000 (18:27 +0000)
Package-Manager: portage-2.1.2_rc4-r5

sys-fs/hfsplusutils/ChangeLog
sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
sys-fs/lufs/ChangeLog
sys-fs/lufs/files/digest-lufs-0.9.7-r3
sys-fs/lufs/lufs-0.9.7-r3.ebuild
sys-fs/reiser4progs/ChangeLog
sys-fs/reiser4progs/reiser4progs-1.0.5.ebuild

index d7f1e8e7b370005a52a1e53731dd4b5fa8ea5214..579976d029a3fa170848a97f7cb50a0aa11374bc 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for sys-fs/hfsplusutils
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/hfsplusutils/ChangeLog,v 1.7 2006/09/23 22:15:17 josejx Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/hfsplusutils/ChangeLog,v 1.8 2007/01/04 18:23:05 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+  hfsplusutils-1.0.4-r1.ebuild:
+  Fix broken autotools handling.
 
   23 Sep 2006; Joseph Jezak <josejx@gentoo.org>
   hfsplusutils-1.0.4-r1.ebuild:
index e8ed0ae869a0d3ffd26e743cb5ec98ac28149b24..044e77a5b1c8ec957600f77c874501bffec80eb4 100644 (file)
@@ -1,8 +1,10 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild,v 1.11 2006/09/23 22:15:17 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild,v 1.12 2007/01/04 18:23:05 flameeyes Exp $
+
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
 
-WANT_AUTOMAKE=1.6
 inherit autotools eutils libtool
 
 MY_P="hfsplus_${PV}"
@@ -26,20 +28,8 @@ src_unpack() {
        epatch ${FILESDIR}/hfsplusutils-1.0.4-glob.patch
        epatch ${FILESDIR}/hfsplusutils-1.0.4-errno.patch
        epatch ${FILESDIR}/hfsplusutils-1.0.4-gcc4.patch
-       #let's avoid the Makefile.cvs since isn't working for us
-       export WANT_AUTOCONF=2.5
-       export WANT_AUTOMAKE=1.6
-       aclocal
-       autoconf
-       autoheader
-       automake -a
-       libtoolize --force --copy
-       elibtoolize
-}
 
-src_compile() {
-       econf || die
-       emake || die
+       eautoreconf
 }
 
 src_install() {
index 0fec8c298d75c6ecbb194e2841d039f06d80fc50..25865946f54cfcf1fc97d80edb69df0a2b84f2f9 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for sys-fs/lufs
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lufs/ChangeLog,v 1.25 2006/06/29 07:57:42 genstef Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lufs/ChangeLog,v 1.26 2007/01/04 18:25:13 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> lufs-0.9.7-r3.ebuild:
+  Fix broken autotools handling.
 
   29 Jun 2006; Stefan Schweizer <genstef@gentoo.org> lufs-0.9.7-r3.ebuild:
   remove version from auto[conf,make} depend, thanks to Mike Auty
index 54c98d3ea5f875040f8317f3f54ea9665062fc80..699b5c0b36f4b24eb4642a973c8d560473e15990 100644 (file)
@@ -1 +1,3 @@
 MD5 23f58fe232254a65df6eb4736a81d524 lufs-0.9.7.tar.gz 537772
+RMD160 d453c2393cd67b04c13dad04870432bb60fa5749 lufs-0.9.7.tar.gz 537772
+SHA256 2d91457906ee2ff1e26de82987019fe2efe22d9c3b6c7741b7ed8fffbae51411 lufs-0.9.7.tar.gz 537772
index 58dc359cdb11f768e3a5fb1e49f411777e1e8569..799318a77334e5867c03dff0065413a99b4a2f94 100644 (file)
@@ -1,8 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lufs/lufs-0.9.7-r3.ebuild,v 1.8 2006/06/29 07:56:43 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lufs/lufs-0.9.7-r3.ebuild,v 1.9 2007/01/04 18:25:13 flameeyes Exp $
 
-inherit eutils
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit eutils autotools
 
 DESCRIPTION="User-mode filesystem implementation"
 HOMEPAGE="http://lufs.sourceforge.net/lufs/"
@@ -27,16 +30,11 @@ src_unpack() {
 
        filesystems="ftpfs localfs sshfs"
        useq amd64 && filesystems="ftpfs localfs"
+
+       eautoreconf
 }
 
 src_compile() {
-       local WANT_AUTOMAKE="1.7" WANT_AUTOCONF="2.5"
-       aclocal
-       automake
-       autoconf
-
-       libtoolize --copy --force
-
        einfo "Compiling for ${filesystems}"
        unset ARCH
        econf $(use_enable debug) || die
index 0052182b4b5436787cef3652e09f1f39b7a2e1a9..d21fc84617ea3c4653b7af13aa64b9564235cf3d 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for sys-fs/reiser4progs
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiser4progs/ChangeLog,v 1.26 2005/09/03 21:07:06 corsair Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiser4progs/ChangeLog,v 1.27 2007/01/04 18:27:03 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+  reiser4progs-1.0.5.ebuild:
+  Fix broken autotools handling.
 
   03 Sep 2005; Markus Rothe <corsair@gentoo.org>
   reiser4progs-1.0.4_p1.ebuild:
index f4b2a32f418ea038ae42d78959160988c344a28b..00c58dc39ee7ecc48d06f17fded90fff5f068228 100644 (file)
@@ -1,8 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiser4progs/reiser4progs-1.0.5.ebuild,v 1.5 2006/08/20 21:23:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiser4progs/reiser4progs-1.0.5.ebuild,v 1.6 2007/01/04 18:27:03 flameeyes Exp $
 
-inherit toolchain-funcs
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit toolchain-funcs autotools
 
 MY_P=${PN}-${PV/_p/-}
 DESCRIPTION="reiser4progs: mkfs, fsck, etc..."
@@ -22,8 +25,9 @@ S=${WORKDIR}/${MY_P}
 src_unpack() {
        unpack ${A}
        cd "${S}"
-       # bundled libtool sucks, so rebuild autotools #74817
-       aclocal && libtoolize -c -f && autoconf && automake || die "autotools failed"
+
+       eautoreconf
+
        cat <<-EOF > run-ldconfig
                #!/bin/sh
                true