net-p2p/cpuminer-opt: 3.12.4.1 version bump
authorCraig Andrews <candrews@gentoo.org>
Sun, 23 Feb 2020 01:58:00 +0000 (20:58 -0500)
committerCraig Andrews <candrews@gentoo.org>
Sun, 23 Feb 2020 01:58:00 +0000 (20:58 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Craig Andrews <candrews@gentoo.org>
net-p2p/cpuminer-opt/Manifest
net-p2p/cpuminer-opt/cpuminer-opt-3.12.4.1.ebuild [new file with mode: 0644]

index a6af048af6508defa2f4bfc9ac1792c38e70099e..846c36980d7db3abad616ed1dd433033569f2315 100644 (file)
@@ -2,3 +2,4 @@ DIST cpuminer-opt-3.12.1.tar.gz 1809074 BLAKE2B 2c19cba4dc070286d7fe39b53b61177b
 DIST cpuminer-opt-3.12.13.tar.gz 1809807 BLAKE2B c971153fc1099dc29ae93ab341e905b3d0252d02468e0f125692a38d00121f82a2825d61e8303e45f4b41f64280d780a02f742eb61d117601a6ce47db57d4d2d SHA512 830371c4e2931101d33d124c86733e9f079ace5b4b59e3b5149db0655c93031dcbbb2dd370d4729b7e697670117c0b6874214a8aa569dcca92c6750dbc88a8b8
 DIST cpuminer-opt-3.12.2.tar.gz 1809424 BLAKE2B fedec681166de95e18d41e4c61ec75a9e1ea1fc1cdb656cebcb303a637a01eb3aba9e0c5cbb5cc710be6a2191dcbef0b1a2c00f0ce349064b25471eac5035c26 SHA512 f8a9c71d673f68418164cc1f0bd7c80b4e5d246b21a8f54432ad9fc87c1962a0ab0a96372018e2d1da55d084b6ce9dcae58dd3f7a0b0e62e595a805fefdb5a10
 DIST cpuminer-opt-3.12.3.1.tar.gz 1809916 BLAKE2B 5ee9f9b1bdcadf9a069fbf46cdad26331504147118b4d79c281ef8322eb3901920b89548afe4b032982668b454db58e658bbb952031fb2f5f764e7e013be006e SHA512 0e6069e7d85b6f2632da919f79183e15dc89ac8ac6c9524a59459bd0c8c4c02fd9b6669434c7f17475f713075763f8a7b939f955866ba4a0b2b1764758096635
+DIST cpuminer-opt-3.12.4.1.tar.gz 1811274 BLAKE2B 9c54bb71d62924ad80eb484ecbdd282b27b022bcbfe37c2ca95dfccbde335f77bf0e28215f77eb381c8866fd7d164b409f48404e2fc7bd09478feb26b0d2ed7f SHA512 2ba603d52d45caeab8cfc8f03c127709791fb058a549af7abb69a62023e5ecc7e51ae670afa600b1563b33dabb50931a090d4d6574fa555b1a892a86d097150f
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.12.4.1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.12.4.1.ebuild
new file mode 100644 (file)
index 0000000..a5d436b
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+       dev-libs/gmp:0
+       dev-libs/jansson
+       >=net-misc/curl-7.15[ssl]
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+       SRC_URI=""
+       EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+       inherit git-r3
+else
+       KEYWORDS="~amd64"
+       SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       append-ldflags -Wl,-z,noexecstack
+       econf --with-crypto --with-curl
+}
+
+src_install() {
+       default
+       systemd_dounit "${FILESDIR}"/${PN}.service
+       insinto "/etc/${PN}"
+       doins cpuminer-conf.json
+}
+
+src_test() {
+       ./cpuminer --cputest || die
+}