net-proxy/pingtunnel: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sat, 21 Mar 2020 14:26:47 +0000 (15:26 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 21 Mar 2020 14:26:47 +0000 (15:26 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
net-proxy/pingtunnel/files/pingtunnel-0.72_makefile.patch
net-proxy/pingtunnel/pingtunnel-0.72.ebuild

index 9dce0992cbdad39d5ebdeb1d62e46b3ac608c7d8..27576bfd434fd0bcc09411a364b0aca4ad516918 100644 (file)
@@ -1,5 +1,5 @@
---- Makefile\r
-+++ Makefile\r
+--- a/Makefile\r
++++ b/Makefile\r
 @@ -2,11 +2,26 @@\r
  # (c) 2004-2009 Daniel Stoedle, daniels@cs.uit.no\r
  # ptunnel.exe target added by Mike Miller, mike@mikeage.net\r
index 9f41ef3c315459847ada681c0e71483566ecbbbc..cc137990d13830ca5eab4529b6fb2b79e2e1ae31 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
 
 DESCRIPTION="Tunnel TCP over ICMP"
 HOMEPAGE="https://www.cs.uit.no/~daniels/PingTunnel"
@@ -12,26 +12,22 @@ SRC_URI="https://www.cs.uit.no/~daniels/PingTunnel/PingTunnel-${PV}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~ppc ~sh ~x86"
-IUSE="doc selinux"
+IUSE="selinux"
 
-DEPEND="
+RDEPEND="
        net-libs/libpcap
-       selinux? ( sys-libs/libselinux )
-"
-RDEPEND="${DEPEND}"
+       selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}"
 
 S="${WORKDIR}"/PingTunnel
 
-src_prepare() {
-       epatch "${FILESDIR}"/${P}_makefile.patch
-}
+PATCHES=( "${FILESDIR}"/${P}_makefile.patch )
+HTML_DOCS=( web/. )
 
-src_compile() {
+src_configure() {
        tc-export CC
-       emake $(usex selinux "SELINUX=1" "SELINUX=0")
 }
 
-src_install() {
-       default
-       use doc && dohtml web/*
+src_compile() {
+       emake SELINUX=$(usex selinux 1 0)
 }