dev-python/mechanize: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 16:48:33 +0000 (17:48 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 16:51:44 +0000 (17:51 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/mechanize/Manifest
dev-python/mechanize/mechanize-0.2.5-r1.ebuild [deleted file]
dev-python/mechanize/mechanize-0.3.6.ebuild [deleted file]

index 50f45f29ca9a28901ac725b4d21d5ea57319d4ce..073fd33d1ced433b3dfd5a20486bb978fa9e3353 100644 (file)
@@ -1,3 +1 @@
-DIST mechanize-0.2.5.tar.gz 383918 BLAKE2B c9951f47067798861de0f153e02985c8d00fb4070960993f2ea1c32ee52d6c937af51cd6e3d291273877da0bb9bee2106b92d3518b180ebfd74eafc764136a10 SHA512 23de1d9a5fba63d76fd577889594dacf5412fb2fccb58908a10ab350a81dd16a7a31019d0b4a59a5ed4115320c7e3585c77eef88dcd80a88a9c3c2da3c28fa68
-DIST mechanize-0.3.6.tar.gz 201845 BLAKE2B be2abf0e573ca41c0b9a8f0632be4d630a4c122cdd6402209619367a01629768fb2b4eb55164f1f511f1549444c015942bcfde2a075514748fbfd56149240dcd SHA512 bc838d826dd8b08f699d4788fae8962746dbc266d892b34eff2f11b16a28ff22357d011fa1b177e813e4d879b36cd83f464173297ba58208a6ba37f9f2f130be
 DIST mechanize-0.4.5.tar.gz 216908 BLAKE2B 67951ad8295a32799768b3719525d45d502bc773c6f2a5e762e3dae97f309c8c265a2cb3efde95c9e8cb65e89dee6ad6ad8585685baa4e9ff1acfd146f115f6f SHA512 51706d5c073501d02fb7395eda30625ed9191324f948073c7d1589df0e507d8b7641ca514ceff55e7d82e899ba6e10c55507c79668976c7654ff0004671d09d2
diff --git a/dev-python/mechanize/mechanize-0.2.5-r1.ebuild b/dev-python/mechanize/mechanize-0.2.5-r1.ebuild
deleted file mode 100644 (file)
index 283c628..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Stateful programmatic web browsing in Python"
-HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/ https://pypi.org/project/mechanize/"
-SRC_URI="http://wwwsearch.sourceforge.net/${PN}/src/${P}.tar.gz"
-
-LICENSE="|| ( BSD ZPL )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-python_test() {
-       # Ignore warnings (https://github.com/jjlee/mechanize/issues/issue/13).
-       # https://github.com/jjlee/mechanize/issues/66
-       "${PYTHON}" -W ignore test.py
-}
-
-python_install_all() {
-       # Fix some paths.
-       sed -e "s:../styles/:styles/:g" -i docs/html/* || die "sed failed"
-       if use doc; then
-               dohtml -r docs/html/ docs/styles
-       fi
-
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/mechanize/mechanize-0.3.6.ebuild b/dev-python/mechanize/mechanize-0.3.6.ebuild
deleted file mode 100644 (file)
index 93d90fa..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Stateful programmatic web browsing in Python"
-HOMEPAGE="https://github.com/python-mechanize/mechanize"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( BSD ZPL )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-python_test() {
-       "${PYTHON}" run_tests.py || die
-}