net-mail/qmail-notify: revbump with EAPI 7
authorPetr Vaněk <arkamar@atlas.cz>
Mon, 7 Oct 2019 11:47:13 +0000 (13:47 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 18 Oct 2019 04:20:52 +0000 (07:20 +0300)
Bug: https://bugs.gentoo.org/696252
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Petr Vaněk <arkamar@atlas.cz>
Closes: https://github.com/gentoo/gentoo/pull/13247
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-mail/qmail-notify/metadata.xml
net-mail/qmail-notify/qmail-notify-0.93-r2.ebuild [new file with mode: 0644]

index 6f49eba8f49693023f393161560b3a2d9e2717c5..7c3db330c141f9be8bccb4de5b09880b5cab7e68 100644 (file)
@@ -1,5 +1,12 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>arkamar@atlas.cz</email>
+               <name>Petr Vaněk</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
 </pkgmetadata>
diff --git a/net-mail/qmail-notify/qmail-notify-0.93-r2.ebuild b/net-mail/qmail-notify/qmail-notify-0.93-r2.ebuild
new file mode 100644 (file)
index 0000000..98b35ab
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Delayed delivery notification for qmail"
+SRC_URI="http://untroubled.org/qmail-notify/archive/${P}.tar.gz"
+HOMEPAGE="http://untroubled.org/qmail-notify/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+       virtual/cron
+       virtual/qmail
+"
+
+src_prepare() {
+       eapply_user
+
+       echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die 'Patching conf-cc failed.'
+       echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die 'Patching conf-ld failed.'
+       sed -e "#'ar #'$(tc-getAR) #" -e "s#'ranlib #'$(tc-getRANLIB) #" -i Makefile || die 'Patching Makefile failed.'
+}
+
+src_install () {
+       exeinto /usr/sbin
+       doexe qmail-notify
+
+       exeinto /etc/cron.hourly
+       doexe "${FILESDIR}"/qmail-notify.cron
+
+       dodoc README ANNOUNCEMENT cron.hourly NEWS
+}
+
+pkg_postinst() {
+       elog
+       elog "Edit qmail-notify.cron in /etc/cron.hourly"
+       elog "to activate qmail-notify!"
+       elog
+}