dev-python/setuptools: Replace python_gen_usedep
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 09:51:48 +0000 (10:51 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 10:14:36 +0000 (11:14 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/setuptools/setuptools-42.0.2.ebuild

index 98b924808219d3497287bd1306e3e222a7396046..4a4fdf1ae70445d538ba31d26b8950e6a293052b 100644 (file)
@@ -27,17 +27,18 @@ RESTRICT="!test? ( test )"
 # Temporary hack to avoid py38 keywording hell.  Please remove when
 # the test deps all have py38.  Also setuptools' test pass with py38,
 # so you need to hack them all in locally before bumping and test.
-TEST_USEDEP=$(python_gen_usedep python2_7 python3_{5,6,7} pypy{,3})
 BDEPEND="
        app-arch/unzip
        test? (
-               dev-python/mock[${TEST_USEDEP}]
-               dev-python/pip[${TEST_USEDEP}]
-               >=dev-python/pytest-3.7.0[${TEST_USEDEP}]
-               dev-python/pytest-fixture-config[${TEST_USEDEP}]
-               dev-python/pytest-virtualenv[${TEST_USEDEP}]
-               dev-python/wheel[${TEST_USEDEP}]
-               virtual/python-futures[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep '
+                       dev-python/mock[${PYTHON_USEDEP}]
+                       dev-python/pip[${PYTHON_USEDEP}]
+                       >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
+                       dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+                       dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+                       dev-python/wheel[${PYTHON_USEDEP}]
+                       virtual/python-futures[${PYTHON_USEDEP}]
+               ' python2_7 python3_{5,6,7} pypy{,3})
        )
 "
 PDEPEND="