sci-libs/coot-data: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Tue, 15 Sep 2015 13:41:21 +0000 (15:41 +0200)
committerJustin Lecher <jlec@gentoo.org>
Tue, 15 Sep 2015 14:03:52 +0000 (16:03 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
sci-libs/coot-data/Manifest
sci-libs/coot-data/coot-data-3.ebuild [new file with mode: 0644]

index b07cf5e53defd979e7a10761bdfaf0e98fdbca75..482a750d3e5b1b67afbf6d7198d8c93c08c384d5 100644 (file)
@@ -1 +1,2 @@
+DIST coot-data-3.tar.gz 6728787 SHA256 44db38506f0f90c097d4855ad81a82a36b49cd1e3ffe7d6ee4728b15109e281a SHA512 7ebe28a619a577b18fc66e714f0bc8347121ebb12f372ac29c1d2d96013e608632921ea26caea3b62744252ae356949de8e04a6513f1a1e0ba30865708c26ffe WHIRLPOOL 59a730017e67687c5d6399252af57f2f97f3197f1b4fd371cf2530f417d1dee7cd6e8792e1a6ce65e619e0b5c2d4c0eaee75ebc822e0c0c9a399e1faeff4d630
 DIST reference-structures-2.tar.gz 6728787 SHA256 44db38506f0f90c097d4855ad81a82a36b49cd1e3ffe7d6ee4728b15109e281a SHA512 7ebe28a619a577b18fc66e714f0bc8347121ebb12f372ac29c1d2d96013e608632921ea26caea3b62744252ae356949de8e04a6513f1a1e0ba30865708c26ffe WHIRLPOOL 59a730017e67687c5d6399252af57f2f97f3197f1b4fd371cf2530f417d1dee7cd6e8792e1a6ce65e619e0b5c2d4c0eaee75ebc822e0c0c9a399e1faeff4d630
diff --git a/sci-libs/coot-data/coot-data-3.ebuild b/sci-libs/coot-data/coot-data-3.ebuild
new file mode 100644 (file)
index 0000000..b4c2d59
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Data for the Crystallographic Object-Oriented Toolkit"
+HOMEPAGE="http://www.biop.ox.ac.uk/coot/"
+SRC_URI="https://www2.mrc-lmb.cam.ac.uk/Personal/pemsley/coot/dependencies/reference-structures.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}"
+
+src_install() {
+       insinto /usr/share/coot
+       doins -r reference-structures
+
+       # Coot looks in the wrong spot for the monomer library
+       # Listens to ccp4's CCP4_LIB rather than CLIBD_MON
+       cat >> "${T}"/coot <<- EOF
+       COOT_REFMAC_LIB_DIR="${EPREFIX}/usr/share/"
+       COOT_REF_STRUCTS="${EPREFIX}/usr/share/coot/reference-structures/"
+       EOF
+
+       newenvd "${T}"/coot 20coot
+}