dev-ml/ocaml-dispatch: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 14 Mar 2017 10:14:19 +0000 (11:14 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 14 Mar 2017 10:21:24 +0000 (11:21 +0100)
Package-Manager: Portage-2.3.4, Repoman-2.3.2

dev-ml/ocaml-dispatch/Manifest [new file with mode: 0644]
dev-ml/ocaml-dispatch/metadata.xml [new file with mode: 0644]
dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild [new file with mode: 0644]

diff --git a/dev-ml/ocaml-dispatch/Manifest b/dev-ml/ocaml-dispatch/Manifest
new file mode 100644 (file)
index 0000000..2ab3e31
--- /dev/null
@@ -0,0 +1 @@
+DIST ocaml-dispatch-0.3.0.tar.gz 51453 SHA256 ebb6bb60ec5a7c17a68711a801006f204b283989b5b9fa1dbe9bd781645f3913 SHA512 0f09eae45a2ecae27d07e247b6a47f307e074342e337e7be262f5183f77090f0aef81fb5c0bf499732bd0a711d4d51775cbcea5e463011f43a1777582d78806b WHIRLPOOL f77f459b34df41506ef1eb13e4d880a0bfed8166e60e2770b0cb6dc3ac2285281f4fc35c2b12465743492d8f730b6ad5585e995a3152a2c5e72638c335158256
diff --git a/dev-ml/ocaml-dispatch/metadata.xml b/dev-ml/ocaml-dispatch/metadata.xml
new file mode 100644 (file)
index 0000000..ffac4d7
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>ml@gentoo.org</email>
+       <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild
new file mode 100644 (file)
index 0000000..0056e66
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Path-based dispatching for client- and server-side applications"
+HOMEPAGE="https://github.com/inhabitedtype/ocaml-dispatch"
+SRC_URI="https://github.com/inhabitedtype/ocaml-dispatch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="javascript"
+
+DEPEND="
+       javascript? ( dev-ml/js_of_ocaml:=[ppx,ocamlopt?] )
+       dev-ml/result:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+       test? ( dev-ml/ounit[ocamlopt?] )
+"
+
+DOCS=( "README.md" )
+
+src_configure() {
+       oasis_configure_opts="$(use_enable javascript js-of-ocaml)" \
+               oasis_src_configure
+}