Can't delete variable that doesn't exist anymore (bug #164280) (trunk r5816:5817...
authorZac Medico <zmedico@gentoo.org>
Sun, 28 Jan 2007 22:14:30 +0000 (22:14 -0000)
committerZac Medico <zmedico@gentoo.org>
Sun, 28 Jan 2007 22:14:30 +0000 (22:14 -0000)
svn path=/main/branches/2.1.2/; revision=5822

bin/repoman

index 08d6ad4c17935ccb3de9d3d2c235a2c87b50776a..a476bd64aa38a9a48c5273975c91d9c5b915b151 100755 (executable)
@@ -1042,12 +1042,20 @@ for x in scanlist:
                Ebuilds that inherit a "Live" eclasss (darcs,subversion,git,cvs,etc..) should
                not be allowed to be marked stable
                """
-               if set(["darcs","cvs","subversion","git"]).intersection(myaux["INHERITED"].split()):
-                       bad_stable_keywords = [keyword for keyword in myaux["KEYWORDS"].split() if not keyword.startswith("~") and not keyword.startswith("-")]
+               if set(["darcs","cvs","subversion","git"]).intersection(
+                       myaux["INHERITED"].split()):
+                       bad_stable_keywords = []
+                       for keyword in myaux["KEYWORDS"].split():
+                               if not keyword.startswith("~") and \
+                                       not keyword.startswith("-"):
+                                       bad_stable_keywords.append(keyword)
+                               del keyword
                        if bad_stable_keywords:
                                stats["LIVEVCS.stable"] += 1
-                               fails["LIVEVCS.stable"].append(x+"/"+y+".ebuild with stable keywords:%s " % bad_stable_keywords)
-                       del keyword, bad_stable_keywords                
+                               fails["LIVEVCS.stable"].append(
+                                       x + "/" + y + ".ebuild with stable keywords:%s " % \
+                                               bad_stable_keywords)
+                       del bad_stable_keywords
 
                if "--ignore-arches" in myoptions:
                        arches = [[repoman_settings["ARCH"], repoman_settings["ARCH"],