net-misc/jlj: EAPI7 revbump
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Wed, 3 Oct 2018 17:52:16 +0000 (19:52 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 5 Oct 2018 21:39:30 +0000 (23:39 +0200)
Closes: https://bugs.gentoo.org/667664
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/10056
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
net-misc/jlj/jlj-2.12-r1.ebuild [new file with mode: 0644]

diff --git a/net-misc/jlj/jlj-2.12-r1.ebuild b/net-misc/jlj/jlj-2.12-r1.ebuild
new file mode 100644 (file)
index 0000000..5534c8e
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple console LiveJournal entry system"
+HOMEPAGE="http://umlautllama.com/projects/perl/#jlj"
+SRC_URI="http://umlautllama.com/projects/perl/${PN}_${PV}.tar.gz"
+
+LICENSE="freedist"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+
+DEPEND="dev-lang/perl"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+       newbin ${PN}.pl ${PN}
+       newdoc .livejournal.rc livejournal.rc
+       dodoc README.JLJ
+}
+
+pkg_postinst() {
+       elog "README.JLJ and a sample livejournal.rc have been installed to"
+       elog "/usr/share/doc/${PF}/"
+}