sys-process/cronie: Warn on update to restart daemon (bug #557406).
authorLars Wendler <polynomial-c@gentoo.org>
Sun, 30 Aug 2015 13:09:46 +0000 (15:09 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sun, 30 Aug 2015 13:10:06 +0000 (15:10 +0200)
Package-Manager: portage-2.2.20.1

sys-process/cronie/cronie-1.5.0-r1.ebuild
sys-process/cronie/cronie-1.5.0.ebuild

index 2bc6434d1e5d05b2c45e718521ed66de4fb7ed9c..77e51d82e9410ce4e0b91a9520311620bb19783a 100644 (file)
@@ -82,4 +82,10 @@ src_install() {
 
 pkg_postinst() {
        cron_pkg_postinst
+
+       if [[ -n "${REPLACING_VERSIONS}" ]] ; then
+               ewarn "You should restart ${PN} daemon or else you might experience segfaults"
+               ewarn "or ${PN} not working reliably anymore."
+               einfo "(see https://bugs.gentoo.org/557406 for details.)"
+       fi
 }
index f4af12a5b38585db9a7fda515059ab37622fc3c3..debcc4af5faee7930b77883545d926aa4412485b 100644 (file)
@@ -82,4 +82,10 @@ src_install() {
 
 pkg_postinst() {
        cron_pkg_postinst
+
+       if [[ -n "${REPLACING_VERSIONS}" ]] ; then
+               ewarn "You should restart ${PN} daemon or else you might experience segfaults"
+               ewarn "or ${PN} not working reliably anymore."
+               einfo "(see https://bugs.gentoo.org/557406 for details.)"
+       fi
 }