Fix deps so it cannot be installed with ghc-6.6
authorDuncan Coutts <dcoutts@gentoo.org>
Sun, 29 Apr 2007 19:10:46 +0000 (19:10 +0000)
committerDuncan Coutts <dcoutts@gentoo.org>
Sun, 29 Apr 2007 19:10:46 +0000 (19:10 +0000)
Package-Manager: portage-2.1.2.2

14 files changed:
dev-haskell/fgl/ChangeLog
dev-haskell/fgl/fgl-5.2.ebuild
dev-haskell/haskell-src/ChangeLog
dev-haskell/haskell-src/haskell-src-1.0.ebuild
dev-haskell/html/ChangeLog
dev-haskell/html/html-1.0.ebuild
dev-haskell/hunit/ChangeLog
dev-haskell/hunit/hunit-1.1.ebuild
dev-haskell/mtl/ChangeLog
dev-haskell/mtl/mtl-1.0.ebuild
dev-haskell/network/ChangeLog
dev-haskell/network/network-1.0.ebuild
dev-haskell/quickcheck/ChangeLog
dev-haskell/quickcheck/quickcheck-1.0.ebuild

index 380a8190c5f9fb56be7f481bc93e5c2c79103aa5..f6c0fae2da5d568add9a3935752070f2e254f77c 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-haskell/fgl
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/fgl/ChangeLog,v 1.14 2007/04/06 16:55:19 cparrott Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/fgl/ChangeLog,v 1.15 2007/04/29 19:02:29 dcoutts Exp $
+
+  29 Apr 2007; Duncan Coutts <dcoutts@gentoo.org> fgl-5.2.ebuild:
+  Fix deps so it cannot be installed with ghc-6.6
 
   06 Apr 2007; Chris Parrott <cparrott@gentoo.org> fgl-5.3.ebuild:
   add ~ppc and ~sparc keywords
index 9e0ac0e712a0d5a97616111da9ce465ccab8dbf8..e87a71de2d3d3cabc7fce4fb08bc0536ff1553c5 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/fgl/fgl-5.2.ebuild,v 1.10 2007/04/02 20:26:23 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/fgl/fgl-5.2.ebuild,v 1.11 2007/04/29 19:02:29 dcoutts Exp $
 
 inherit ghc-package
 
@@ -13,7 +13,8 @@ SLOT="0"
 KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
 IUSE=""
 
-DEPEND="=virtual/ghc-6.4*"
+DEPEND="=virtual/ghc-6.4*
+               !>=virtual/ghc-6.6"
 
 pkg_setup () {
        ghc-package_pkg_setup
index 56a91319f7443b15502fd153ad0ec5f41f37eeba..5bc8ed994c8beb091c2423c94229d03f03d69cf4 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-haskell/haskell-src
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src/ChangeLog,v 1.13 2007/04/06 16:58:09 cparrott Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src/ChangeLog,v 1.14 2007/04/29 19:02:57 dcoutts Exp $
+
+  29 Apr 2007; Duncan Coutts <dcoutts@gentoo.org> haskell-src-1.0.ebuild:
+  Fix deps so it cannot be installed with ghc-6.6
 
   06 Apr 2007; Chris Parrott <cparrott@gentoo.org>
   haskell-src-1.0-r1.ebuild:
index 827ff5d46f0dcc3dd04b63c18dce62b957778e10..4f050f63f36657974a3c55052a6a3457f517f8f8 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src/haskell-src-1.0.ebuild,v 1.10 2007/04/02 20:29:56 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haskell-src/haskell-src-1.0.ebuild,v 1.11 2007/04/29 19:02:57 dcoutts Exp $
 
 inherit ghc-package
 
@@ -13,7 +13,8 @@ SLOT="0"
 KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
 IUSE=""
 
-DEPEND="=virtual/ghc-6.4*"
+DEPEND="=virtual/ghc-6.4*
+               !>=virtual/ghc-6.6"
 
 pkg_setup () {
        ghc-package_pkg_setup
index c0d7ab71820d820a454361555aed102737e07179..0dfdf88cfe733970e40cc344a6e991ead6a2a325 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-haskell/html
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/html/ChangeLog,v 1.13 2007/04/06 17:06:50 cparrott Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/html/ChangeLog,v 1.14 2007/04/29 19:03:48 dcoutts Exp $
+
+  29 Apr 2007; Duncan Coutts <dcoutts@gentoo.org> html-1.0.ebuild:
+  Fix deps so it cannot be installed with ghc-6.6
 
   06 Apr 2007; Chris Parrott <cparrott@gentoo.org> html-1.0-r1.ebuild:
   added ~ppc and ~sparc keywords
index f523a9dedc0bc08965e1118c7956baada6f1e99e..da20eaf92fb86a62d6ee16db23a08a2d2f7a6aa6 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/html/html-1.0.ebuild,v 1.10 2007/04/02 20:33:18 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/html/html-1.0.ebuild,v 1.11 2007/04/29 19:03:48 dcoutts Exp $
 
 inherit ghc-package
 
@@ -13,7 +13,8 @@ SLOT="0"
 KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
 IUSE=""
 
-DEPEND="=virtual/ghc-6.4*"
+DEPEND="=virtual/ghc-6.4*
+               !>=virtual/ghc-6.6"
 
 pkg_setup () {
        ghc-package_pkg_setup
index b103e0073219d5e18e96d99a9e760fd75ace35f0..849efad7bd0e2d9c5d0e88e18ff5fe18b1fd356a 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-haskell/hunit
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/ChangeLog,v 1.13 2007/04/06 17:11:57 cparrott Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/ChangeLog,v 1.14 2007/04/29 19:04:15 dcoutts Exp $
+
+  29 Apr 2007; Duncan Coutts <dcoutts@gentoo.org> hunit-1.1.ebuild:
+  Fix deps so it cannot be installed with ghc-6.6
 
   06 Apr 2007; Chris Parrott <cparrott@gentoo.org> hunit-1.1-r1.ebuild:
   added ~ppc and ~sparc keywords
index 26bc11bf33d124409b5400153af1643e956aab66..716723b7fd8fa91bfa6f0feb8843804916fbe20b 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/hunit-1.1.ebuild,v 1.10 2007/04/02 20:31:05 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/hunit-1.1.ebuild,v 1.11 2007/04/29 19:04:15 dcoutts Exp $
 
 inherit ghc-package
 
@@ -13,7 +13,8 @@ SLOT="0"
 KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
 IUSE=""
 
-DEPEND="=virtual/ghc-6.4*"
+DEPEND="=virtual/ghc-6.4*
+               !>=virtual/ghc-6.6"
 
 pkg_setup () {
        ghc-package_pkg_setup
index 1c4e64f9eec30f84d192a3c6bd7171650a907e3e..843d4c01aa8f563ee7013c0cd2a1fb4d581a5735 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-haskell/mtl
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mtl/ChangeLog,v 1.13 2007/04/06 16:48:06 cparrott Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mtl/ChangeLog,v 1.14 2007/04/29 19:05:58 dcoutts Exp $
+
+  29 Apr 2007; Duncan Coutts <dcoutts@gentoo.org> mtl-1.0.ebuild:
+  Fix deps so it cannot be installed with ghc-6.6
 
   06 Apr 2007; Chris Parrott <cparrott@gentoo.org> mtl-1.0-r1.ebuild:
   added ~ppc and ~sparc keywords
index d7081ffcc29b1dc536d78971b2da8b5d2228eecd..142f33de7f5767f487723a8020f0a42478a6a698 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mtl/mtl-1.0.ebuild,v 1.10 2007/04/02 20:28:49 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mtl/mtl-1.0.ebuild,v 1.11 2007/04/29 19:05:58 dcoutts Exp $
 
 inherit ghc-package
 
@@ -13,7 +13,8 @@ SLOT="0"
 KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
 IUSE=""
 
-DEPEND="=virtual/ghc-6.4*"
+DEPEND="=virtual/ghc-6.4*
+               !>=virtual/ghc-6.6"
 
 pkg_setup () {
        ghc-package_pkg_setup
index ac8bd477016d53b88279821a101cbf4784b53247..71013e20180189068bd73050292d582430ed9e7d 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-haskell/network
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network/ChangeLog,v 1.13 2007/04/06 16:48:06 cparrott Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network/ChangeLog,v 1.14 2007/04/29 19:06:34 dcoutts Exp $
+
+  29 Apr 2007; Duncan Coutts <dcoutts@gentoo.org> network-1.0.ebuild:
+  Fix deps so it cannot be installed with ghc-6.6
 
   06 Apr 2007; Chris Parrott <cparrott@gentoo.org> network-2.0.ebuild:
   added ~ppc and ~sparc keywords
index f1e77801af2f34d2cea6781624aad836da8b8bf6..d66ce4fb2a3611c82759467987d476c0752d2878 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network/network-1.0.ebuild,v 1.10 2007/04/02 20:34:11 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/network/network-1.0.ebuild,v 1.11 2007/04/29 19:06:34 dcoutts Exp $
 
 inherit ghc-package
 
@@ -13,7 +13,8 @@ SLOT="0"
 KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
 IUSE=""
 
-DEPEND="=virtual/ghc-6.4*"
+DEPEND="=virtual/ghc-6.4*
+               !>=virtual/ghc-6.6"
 
 pkg_setup () {
        ghc-package_pkg_setup
index 18dff0c8d49162bfd9f57946cd61d4fa9a65b8cf..7d2ceaf7264f465e099063137139498a87f35077 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-haskell/quickcheck
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.13 2007/04/06 17:15:08 cparrott Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.14 2007/04/29 19:10:46 dcoutts Exp $
+
+  29 Apr 2007; Duncan Coutts <dcoutts@gentoo.org> quickcheck-1.0.ebuild:
+  Fix deps so it cannot be installed with ghc-6.6
 
   06 Apr 2007; Chris Parrott <cparrott@gentoo.org> quickcheck-1.0-r1.ebuild:
   added ~ppc and ~sparc keywords
index 716a50de23cf54a43ccc9271eac9b72665d65b08..c433a5ebb626820e10db76c8acf9231a65bbb2dd 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-1.0.ebuild,v 1.10 2007/04/02 20:35:39 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-1.0.ebuild,v 1.11 2007/04/29 19:10:46 dcoutts Exp $
 
 inherit ghc-package
 
@@ -13,7 +13,8 @@ SLOT="0"
 KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
 IUSE=""
 
-DEPEND="=virtual/ghc-6.4*"
+DEPEND="=virtual/ghc-6.4*
+               !>=virtual/ghc-6.6"
 
 pkg_setup () {
        ghc-package_pkg_setup