app-vim/easy-align: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Tue, 22 Jan 2019 22:58:12 +0000 (23:58 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Tue, 22 Jan 2019 22:58:12 +0000 (23:58 +0100)
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
RepoMan-Options: --force

app-vim/easy-align/easy-align-2.10.0-r1.ebuild [new file with mode: 0644]

diff --git a/app-vim/easy-align/easy-align-2.10.0-r1.ebuild b/app-vim/easy-align/easy-align-2.10.0-r1.ebuild
new file mode 100644 (file)
index 0000000..dcb2ed0
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN=vim-${PN}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: a simple alignment plugin"
+HOMEPAGE="https://github.com/junegunn/vim-easy-align https://www.vim.org/scripts/script.php?script_id=4520"
+SRC_URI="https://github.com/junegunn/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+       rm -rv test || die
+}