dev-python/python-senlinclient: adding for heat
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 3 Oct 2016 20:18:07 +0000 (15:18 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 3 Oct 2016 20:36:13 +0000 (15:36 -0500)
Package-Manager: portage-2.3.0

dev-python/python-senlinclient/Manifest [new file with mode: 0644]
dev-python/python-senlinclient/metadata.xml [new file with mode: 0644]
dev-python/python-senlinclient/python-senlinclient-1.0.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/python-senlinclient/Manifest b/dev-python/python-senlinclient/Manifest
new file mode 100644 (file)
index 0000000..4cfb494
--- /dev/null
@@ -0,0 +1 @@
+DIST python-senlinclient-1.0.0.tar.gz 101396 SHA256 eb4fe96425cfc2c8137b97f2ab9071ebea1a2862b334ab1882513379fed12876 SHA512 3e98cc9a238250ca4069289343011d27d9bf6b35e0c8709bbf209b7774ff7b84151533104795fcc21403202cf6c834503685a9994d320a48aa690a854e1570f9 WHIRLPOOL 559b26f5be8ef0e99c63474f79b22e7baa05ca38b804c309fde4459668dbceba022175d8db156fc283af66bb87322ffe31e58cdd39c022d25f1af2e1ae00d497
diff --git a/dev-python/python-senlinclient/metadata.xml b/dev-python/python-senlinclient/metadata.xml
new file mode 100644 (file)
index 0000000..77fd747
--- /dev/null
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>openstack@gentoo.org</email>
+               <name>Openstack</name>
+       </maintainer>
+       <longdescription lang="en">
+    This is a client for the OpenStack Senlin API.
+  </longdescription>
+       <upstream>
+               <remote-id type="pypi">python-senlinclient</remote-id>
+               <remote-id type="github">openstack/python-senlinclient</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-senlinclient/python-senlinclient-1.0.0.ebuild b/dev-python/python-senlinclient/python-senlinclient-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..a35f039
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Senlin API"
+HOMEPAGE="https://github.com/openstack/python-senlinclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+       >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+       <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+       >=dev-python/openstacksdk-0.9.4
+       >=dev-python/osc-lib-1.0.2
+       >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+       >=dev-python/python-heatclient-1.4.0
+       >=dev-python/pyyaml-3.1.0
+       >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+       # built in...
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}