dev-tex/detex: bump EAPI and stuff
authorAaron Bauman <bman@gentoo.org>
Sat, 9 Nov 2019 19:54:52 +0000 (14:54 -0500)
committerAaron Bauman <bman@gentoo.org>
Sat, 9 Nov 2019 19:56:28 +0000 (14:56 -0500)
* This is a legacy version and a newer version is upstream
* Update homepage
* Use HTTPS
* drop eutils
* use src_prepare
* remove unneeded dies

Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-tex/detex/detex-2.8-r1.ebuild
dev-tex/detex/files/detex-2.8-ldflags.patch

index 9f4543a4c0b5e7adcc43ef764e95ad22a1509533..8245b520dec0d3653077e1110466479ada2c2695 100644 (file)
@@ -1,13 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
 
 DESCRIPTION="A filter program that removes the LaTeX (or TeX) control sequences"
-HOMEPAGE="http://www.cs.purdue.edu/homes/trinkle/detex/"
-SRC_URI="http://www.cs.purdue.edu/homes/trinkle/detex/${P}.tar"
+HOMEPAGE="https://www.cs.purdue.edu/homes/trinkle/detex/index-legacy.html"
+SRC_URI="https://www.cs.purdue.edu/homes/trinkle/detex/${P}.tar"
 
 LICENSE="BSD"
 SLOT="0"
@@ -17,26 +17,26 @@ IUSE=""
 DEPEND="sys-devel/flex"
 RDEPEND=""
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}/${P}-ldflags.patch"
+PATCHES=( "${FILESDIR}/${P}-ldflags.patch" )
+
+src_prepare() {
        sed -i \
                -e "s:CFLAGS    = -O \${DEFS}:CFLAGS    = ${CFLAGS} \${DEFS}:" \
                -e 's:LEX       = lex:#LEX      = lex:' \
                -e 's:#LEX      = flex:LEX      = flex:' \
                -e 's:#DEFS     += ${DEFS} -DNO_MALLOC_DECL:DEFS += -DNO_MALLOC_DECL:' \
                -e 's:LEXLIB    = -ll:LEXLIB    = -lfl:' \
-               Makefile || die "sed failed"
+               Makefile || die "Fixing Makefile failed"
+       default
 }
 
 src_compile() {
        tc-export CC
-       emake || die "emake failed"
+       emake
 }
 
 src_install() {
-       dobin detex || die
+       dobin detex
        dodoc README
        doman detex.1l
 }
index e70c000b0c5b4c0d72b7768516da2d12a248273a..3ae3c2ff054000c58c205fae6bfecef371026bd5 100644 (file)
@@ -4,8 +4,8 @@ bug #209731
 
 Index: detex-2.8/Makefile
 ===================================================================
---- detex-2.8.orig/Makefile
-+++ detex-2.8/Makefile
+--- a/Makefile
++++ b/Makefile
 @@ -104,7 +104,7 @@ D_OBJ      = detex.o
  all:  ${PROGS}