Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
inherit eutils flag-o-matic toolchain-funcs
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
S=${WORKDIR}
+PATCHES=( "${FILESDIR}"/bbtools-${PV}-gentoo.patch )
+
src_prepare() {
mv BBINFO.cpp bbinfo.cpp || die
mv BITS.CPP bits.cpp || die
mv BITS.H bits.h || die
mv bbdmux.CPP bbdmux.cpp || die
- rm *.ide
+ rm *.ide || die
edos2unix *.cpp *.h
- epatch "${FILESDIR}"/bbtools-${PV}-gentoo.patch
+ default
+}
+src_configure() {
append-lfs-flags
tc-export CXX
}
---- bits.h
-+++ bits.h 2003-10-20 22:04:30.000000000 +0000
+--- a/bits.h
++++ b/bits.h
@@ -15,4 +15,4 @@
int seek_sync(unsigned int sync, int N);
unsigned int look_ahead(int N);
-
+#define strlwr(x)
---- bbainfo.cpp
-+++ bbainfo.cpp 2003-10-20 22:19:15.000000000 +0000
+--- a/bbainfo.cpp
++++ b/bbainfo.cpp
@@ -97,8 +97,8 @@
{
int i, framesize, skip;
if (padding_bit)
framesize++;
---- bbinfo.cpp
-+++ bbinfo.cpp 2003-10-20 22:16:43.000000000 +0000
+--- a/bbinfo.cpp
++++ b/bbinfo.cpp
@@ -984,7 +984,7 @@
bit_rate = (k & 0xF0) >> 4;
freq = (k & 0x0C) >> 2;
frequency[freq]) * slots[3 - layer]) - 4;
if (padding_bit)
streams[PID]->audio_sync += 1;
---- Makefile
-+++ Makefile 2003-10-20 22:26:07.000000000 +0000
+--- a/Makefile
++++ b/Makefile
@@ -0,0 +1,25 @@
+all: bbainfo bbdmux bbinfo bbvinfo
+