media-video/bbtools: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 13:20:49 +0000 (14:20 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 13:20:49 +0000 (14:20 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-video/bbtools/bbtools-1.9.ebuild
media-video/bbtools/files/bbtools-1.9-gentoo.patch

index f824754bccb57da32c890811a0cf406838157da7..392e8c0d3afe8e276094bea9906aa147ce27b8cb 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
 inherit eutils flag-o-matic toolchain-funcs
 
@@ -12,22 +12,25 @@ SRC_URI="http://files.digital-digest.com/downloads/files/encode/bbtool${PV/./}_s
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
 
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
 
 S=${WORKDIR}
 
+PATCHES=( "${FILESDIR}"/bbtools-${PV}-gentoo.patch )
+
 src_prepare() {
        mv BBINFO.cpp bbinfo.cpp || die
        mv BITS.CPP bits.cpp || die
        mv BITS.H bits.h || die
        mv bbdmux.CPP bbdmux.cpp || die
-       rm *.ide
+       rm *.ide || die
        edos2unix *.cpp *.h
 
-       epatch "${FILESDIR}"/bbtools-${PV}-gentoo.patch
+       default
+}
 
+src_configure() {
        append-lfs-flags
        tc-export CXX
 }
index 7f9ff7ab62791c59ca00d0e29e30b7a63f79de1d..98efb8e534de0e956d138a6ae9e48037cf280edb 100644 (file)
@@ -1,13 +1,13 @@
---- bits.h
-+++ bits.h     2003-10-20 22:04:30.000000000 +0000
+--- a/bits.h
++++ b/bits.h
 @@ -15,4 +15,4 @@
  int seek_sync(unsigned int sync, int N);
  unsigned int look_ahead(int N);
  
 -
 +#define strlwr(x)
---- bbainfo.cpp
-+++ bbainfo.cpp        2003-10-20 22:19:15.000000000 +0000
+--- a/bbainfo.cpp
++++ b/bbainfo.cpp
 @@ -97,8 +97,8 @@
  {
    int i, framesize, skip;
@@ -19,8 +19,8 @@
  
    if (padding_bit)
      framesize++;
---- bbinfo.cpp
-+++ bbinfo.cpp 2003-10-20 22:16:43.000000000 +0000
+--- a/bbinfo.cpp
++++ b/bbinfo.cpp
 @@ -984,7 +984,7 @@
                            bit_rate = (k & 0xF0) >> 4;
                            freq = (k & 0x0C) >> 2;
@@ -48,8 +48,8 @@
                                        frequency[freq]) * slots[3 - layer]) - 4;
                      if (padding_bit)
                        streams[PID]->audio_sync += 1;
---- Makefile
-+++ Makefile   2003-10-20 22:26:07.000000000 +0000
+--- a/Makefile
++++ b/Makefile
 @@ -0,0 +1,25 @@
 +all: bbainfo bbdmux bbinfo bbvinfo
 +