new version, SRC_URI corrections. Plus this really belongs to games people
authorGeorge Shapovalov <george@gentoo.org>
Wed, 31 Dec 2003 19:31:16 +0000 (19:31 +0000)
committerGeorge Shapovalov <george@gentoo.org>
Wed, 31 Dec 2003 19:31:16 +0000 (19:31 +0000)
media-libs/atlas-c++/ChangeLog
media-libs/atlas-c++/Manifest
media-libs/atlas-c++/atlas-c++-0.4.5.ebuild
media-libs/atlas-c++/atlas-c++-0.4.6.ebuild [new file with mode: 0644]
media-libs/atlas-c++/files/digest-atlas-c++-0.4.6 [new file with mode: 0644]

index cb312964d3c5d40c417ec39be7da52d8fa054108..75b12d71da3fdafd2a67cc82def1af5576026a6c 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for media-libs/atlas-c++
 # Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.5 2003/02/12 07:06:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.6 2003/12/31 19:31:04 george Exp $
+
+*atlas-c++-0.4.6 (31 Dec 2003)
+
+  31 Dec 2003; George Shapovalov <george@gentoo.org> atlas-c++-0.4.{5,6).ebuild :
+  new version. Corrected SRC_URI's (site has moved)
+  Also looks like this package has been long abandoned (and its not my epitarhy either,
+  I only got it (I suspect) because of atlas in name)
+  any game dev to pick it up?
 
   06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
  
index 661a783a82fc5c5442a1f786ea7dab9047170997..5afb2e30ff3fe58229d615a46fff298c78592b67 100644 (file)
@@ -1,5 +1,7 @@
-MD5 e79525a96a680fef782b142b1957cf00 ChangeLog 562
+MD5 dc5118d07b7b0263fec920c6857df4b1 atlas-c++-0.4.5.ebuild 796
 MD5 7cda47755fc5e939476501beb5e2b945 atlas-c++-0.4.4.ebuild 806
-MD5 7f1b776970a8240535315bb8dfbca2eb atlas-c++-0.4.5.ebuild 799
+MD5 00c296e88f462ef43d0e8ebf10e45120 atlas-c++-0.4.6.ebuild 964
+MD5 36d733f3a5c0ef545b9957ea059bcab7 ChangeLog 901
 MD5 4e8ea0f33c831ce381b1de0f0aaf2acb files/digest-atlas-c++-0.4.4 68
 MD5 2f6bbb72fcabdcb3de5aebd38bd22ec1 files/digest-atlas-c++-0.4.5 68
+MD5 6229bff81da72033335d73570d5ca80f files/digest-atlas-c++-0.4.6 68
index 02ae122de4377a57d0248f6b52485a4d758700ab..d1066f13324003d782b1847fb0d4f59d0df97228 100644 (file)
@@ -1,13 +1,13 @@
 # Copyright 1999-2003 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild,v 1.2 2003/02/13 12:40:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild,v 1.3 2003/12/31 19:31:04 george Exp $
 
 MY_PN="Atlas-C++"
 MY_P=${MY_PN}-${PV}
 S=${WORKDIR}/${MY_P}
 DESCRIPTION="Atlas protocol standard implementation in C++.  Atlas protocol is used in role playing games at worldforge."
 HOMEPAGE="http://www.worldforge.net"
-SRC_URI="ftp://victor.worldforge.org/pub/worldforge/libs/${MY_PN}/${MY_P}.tar.bz2"
+SRC_URI="ftp://ftp.worldforge.org/pub/worldforge/libs/${MY_PN}/${MY_P}.tar.bz2"
 
 SLOT="0"
 LICENSE="LGPL-2.1"
diff --git a/media-libs/atlas-c++/atlas-c++-0.4.6.ebuild b/media-libs/atlas-c++/atlas-c++-0.4.6.ebuild
new file mode 100644 (file)
index 0000000..7ec52ba
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.4.6.ebuild,v 1.1 2003/12/31 19:31:04 george Exp $
+
+MY_PN="Atlas-C++"
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Atlas protocol standard implementation in C++.  Atlas protocol is used in role playing games at worldforge."
+HOMEPAGE="http://www.worldforge.net"
+SRC_URI="ftp://ftp.worldforge.org/pub/worldforge/libs/${MY_PN}/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+       >=dev-libs/libsigc++-1.2*"
+
+src_compile() {
+
+       econf || die
+       emake || die
+
+}
+
+src_install() {
+       make DESTDIR=${D} install || die
+       #dodoc will install all these docs and a few more
+       rm -rf ${D}/usr/share/doc/${My_P}
+       #PR=r0 in this case, but don't fprget to add ${PR} here for non-zero revisions!
+
+       dodoc AUTHORS COPYING ChangeLog NEWS README ROADMAP THANKS TODO
+}
diff --git a/media-libs/atlas-c++/files/digest-atlas-c++-0.4.6 b/media-libs/atlas-c++/files/digest-atlas-c++-0.4.6
new file mode 100644 (file)
index 0000000..409a21e
--- /dev/null
@@ -0,0 +1 @@
+MD5 5ef0a12001d3924baa2742171af31ed3 Atlas-C++-0.4.6.tar.bz2 195957