dev-python/python-gnupg: 0.4.6
authorSebastian Pipping <sping@gentoo.org>
Sat, 18 Apr 2020 14:00:43 +0000 (16:00 +0200)
committerSebastian Pipping <sping@gentoo.org>
Sat, 18 Apr 2020 14:01:16 +0000 (16:01 +0200)
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.99, Repoman-2.3.22

dev-python/python-gnupg/Manifest
dev-python/python-gnupg/python-gnupg-0.4.6.ebuild [new file with mode: 0644]

index 7b1efc11dc6d925ac30f9c721e68e1433cb9ff6c..ca1697d685116dc85e17d4ca1f1184256b8f1e3b 100644 (file)
@@ -1 +1,2 @@
 DIST python-gnupg-0.4.5.tar.gz 48792 BLAKE2B 1bf9cc1c8efafd4fa783574724852d0f168d4d4d4ec188bade9a3ff21be61cc1b087bd4ae72f11f189d182cd49c765d9b57ef22d954a69555c0368f1d863f1fd SHA512 441b49e1f87a7e8e3abf2d6e90f677dc33f1b66a36483787f972378127f31308bacc5e200ae254dd75942191d2fabd61ca5a2f200cf5400be70957942f889ca4
+DIST python-gnupg-0.4.6.tar.gz 52527 BLAKE2B ac616bebac3c5d0ac35c2c1a9353b4ee700848be2469fabc4b6df9f328868638f61211adc786ec59a24f122106ae53cce68d0f16c33b64c2d3d27cb94bf17956 SHA512 33b98bdd1c7d211d31173bbea2358fdfd2dabdbd5e70d4b33035a0edbf666bdba7319ffc847c8617f2626d1bf5a91102f1103c0bfe651fcd709d51ee821be104
diff --git a/dev-python/python-gnupg/python-gnupg-0.4.6.ebuild b/dev-python/python-gnupg/python-gnupg-0.4.6.ebuild
new file mode 100644 (file)
index 0000000..499da4e
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python wrapper for GnuPG"
+HOMEPAGE="
+       https://bitbucket.org/vinay.sajip/python-gnupg
+       https://pypi.org/project/python-gnupg/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-crypt/gnupg"
+DEPEND="${RDEPEND}"
+
+python_test() {
+       # NO_EXTERNAL_TESTS must be enabled,
+       # to disable all tests, which need internet access.
+       NO_EXTERNAL_TESTS=1 "${PYTHON}" test_gnupg.py || die "Tests failed with ${EPYTHON}"
+}