dev-python/sphinxcontrib-httpexample: New package
authorPatrick McLean <patrick.mclean@sony.com>
Thu, 7 May 2020 00:16:10 +0000 (17:16 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 7 May 2020 00:16:25 +0000 (17:16 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/sphinxcontrib-httpexample/Manifest [new file with mode: 0644]
dev-python/sphinxcontrib-httpexample/metadata.xml [new file with mode: 0644]
dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild [new file with mode: 0644]

diff --git a/dev-python/sphinxcontrib-httpexample/Manifest b/dev-python/sphinxcontrib-httpexample/Manifest
new file mode 100644 (file)
index 0000000..fe36e36
--- /dev/null
@@ -0,0 +1 @@
+DIST sphinxcontrib-httpexample-0.10.3.tar.gz 30489 BLAKE2B 1100f28398d0d23559fb7ebea8263be5da6f2db09e9d5f48513d80d2cd580d2ff436df84b532eba8fb0c30eb3787a86f57f75750aeb0857b52af09885ba9a124 SHA512 de776f20e566a5b2ec4fcbad82d2ac39988ccf651a14d38d353dfd9cda7c15289acbb41db56df9189e42c2637bfd70fd4915d19d4ee718ddd4de476ddc34151f
diff --git a/dev-python/sphinxcontrib-httpexample/metadata.xml b/dev-python/sphinxcontrib-httpexample/metadata.xml
new file mode 100644 (file)
index 0000000..39ac3a9
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>chutzpah@gentoo.org</email>
+    <name>Patrick McLean</name>
+  </maintainer>
+  <maintainer type="person">
+    <email>williamh@gentoo.org</email>
+    <name>William Hubbs</name>
+  </maintainer>
+  <maintainer type="person">
+    <email>vpayno+gentoo@gmail.com</email>
+    <name>Victor Payno</name>
+  </maintainer>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild b/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
new file mode 100644 (file)
index 0000000..62cfbf4
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Adds example directive for sphinx-contrib httpdomain"
+HOMEPAGE="https://github.com/collective/sphinxcontrib-httpexample"
+SRC_URI="https://github.com/collective/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/astunparse[${PYTHON_USEDEP}]
+       dev-python/docutils[${PYTHON_USEDEP}]
+       dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+       dev-python/sphinx[${PYTHON_USEDEP}]
+       dev-python/sphinxcontrib-httpdomain[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+       test? (
+               dev-python/snapshottest[${PYTHON_USEDEP}]
+               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+               dev-python/sphinx-testing[${PYTHON_USEDEP}]
+       )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+       sed -e "s:pytest-runner::" -i setup.cfg || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       distutils_install_for_testing
+       pytest -vv || die "tests fail with ${EPYTHON}"
+}