Ebuild clean up, fixed problem with new libpng, bug #136452
authorKarol Wojtaszek <sekretarz@gentoo.org>
Sun, 18 Jun 2006 10:35:41 +0000 (10:35 +0000)
committerKarol Wojtaszek <sekretarz@gentoo.org>
Sun, 18 Jun 2006 10:35:41 +0000 (10:35 +0000)
Package-Manager: portage-2.1.1_pre1-r1

media-gfx/imagemagick/ChangeLog
media-gfx/imagemagick/files/imagemagick-6.2.6.0-png.patch [new file with mode: 0644]
media-gfx/imagemagick/imagemagick-6.2.6.0.ebuild

index ec5ac6cf496f07aa535269d4649b1c2b4170ed16..6c1517941fb1fcdcc6b2434a82864188c613e831 100644 (file)
@@ -1,6 +1,16 @@
 # ChangeLog for media-gfx/imagemagick
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/ChangeLog,v 1.182 2006/05/26 16:48:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/ChangeLog,v 1.183 2006/06/18 10:35:40 sekretarz Exp $
+
+  18 Jun 2006; Karol Wojtaszek <sekretarz@gentoo.org>
+  +files/imagemagick-6.2.6.0-png.patch, -imagemagick-6.1.8.8.ebuild,
+  -imagemagick-6.2.0.4.ebuild, -imagemagick-6.2.0.6.ebuild,
+  -imagemagick-6.2.1.5.ebuild, -imagemagick-6.2.1.5-r1.ebuild,
+  -imagemagick-6.2.2.0.ebuild, -imagemagick-6.2.2.0-r1.ebuild,
+  -imagemagick-6.2.2.3.ebuild, -imagemagick-6.2.4.2.ebuild,
+  -imagemagick-6.2.5.2.ebuild, -imagemagick-6.2.5.4.ebuild,
+  imagemagick-6.2.6.0.ebuild:
+  Ebuild clean up, fixed problem with new libpng, bug #136452
 
   26 May 2006; Diego Pettenò <flameeyes@gentoo.org>
   imagemagick-6.2.6.0.ebuild:
diff --git a/media-gfx/imagemagick/files/imagemagick-6.2.6.0-png.patch b/media-gfx/imagemagick/files/imagemagick-6.2.6.0-png.patch
new file mode 100644 (file)
index 0000000..7bcc46b
--- /dev/null
@@ -0,0 +1,22 @@
+--- coders/png.c       2006-01-08 06:41:08.000000000 +0100
++++ coders/png.c       2006-06-10 23:17:09.000000000 +0200
+@@ -1753,7 +1753,7 @@
+ #if defined(PNG_USE_PNGGCCRD) && defined(PNG_ASSEMBLER_CODE_SUPPORTED) \
+ && (PNG_LIBPNG_VER >= 10200)
+   /* Disable thread-unsafe features of pnggccrd */
+-  if (png_access_version() >= 10200)
++  if (png_access_version_number() >= 10200)
+   {
+     png_uint_32 mmx_disable_mask=0;
+     png_uint_32 asm_flags;
+@@ -1762,8 +1762,8 @@
+                         | PNG_ASM_FLAG_MMX_READ_FILTER_SUB   \
+                         | PNG_ASM_FLAG_MMX_READ_FILTER_AVG   \
+                         | PNG_ASM_FLAG_MMX_READ_FILTER_PAETH );
+-    asm_flags=png_get_asm_flags(png_ptr);
+-    png_set_asm_flags(png_ptr, asm_flags & ~mmx_disable_mask);
++    asm_flags=png_get_asm_flags(ping);
++    png_set_asm_flags(ping, asm_flags & ~mmx_disable_mask);
+   }
+ #endif
index fdb067f9257cbc40c5ed4997ce0fd8f24e3b3e87..51efbcde414fd9f0a6fbbc23cc29fc3a44771bd9 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/imagemagick-6.2.6.0.ebuild,v 1.3 2006/05/26 16:48:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/imagemagick-6.2.6.0.ebuild,v 1.4 2006/06/18 10:35:40 sekretarz Exp $
 
 inherit eutils perl-app multilib
 
@@ -56,7 +56,7 @@ src_unpack() {
        cd "${S}"
        chmod +x config.sub
        epatch "${FILESDIR}"/${PN}-6.2.5.4-docs.patch
-#      epatch "${FILESDIR}"/imagemagick-perlmagick.patch
+       epatch "${FILESDIR}/${P}-png.patch"
 }
 
 src_compile() {