dev-libs/libmateweather: Version bump to 1.16.1
authorEttore Di Giacinto <mudler@gentoo.org>
Sun, 11 Dec 2016 16:10:30 +0000 (17:10 +0100)
committerEttore Di Giacinto <mudler@gentoo.org>
Sun, 11 Dec 2016 16:13:42 +0000 (17:13 +0100)
Package-Manager: portage-2.3.1

dev-libs/libmateweather/Manifest
dev-libs/libmateweather/libmateweather-1.16.1.ebuild [new file with mode: 0644]

index 69e0afed5445bdcd55f2f831bbfa438bda1bf4a7..ee8ea0a28decbb519f16bb4d1a65535b03a6acd7 100644 (file)
@@ -1,2 +1,3 @@
 DIST libmateweather-1.12.2.tar.xz 3394620 SHA256 9e94acc29b86db0eeb4ba1c0b0d64476a537a8deb31830b98bbeae74e6f2e944 SHA512 057037c6983ba6d21ae8c9af67d5b1bde1f7da81dbc5ef89e5eabc1b844178d2d121d29d90484baa001d22cb24e8dc832bcb1ad2702460d22f48db430fa20fd9 WHIRLPOOL 1c168a94980a42ee8e4f533138a4bdaa7ee2a07d08b5b8ae172402540d7029b893450b5c12732604698cfcd5f536258f7bcab21e99044ce09260bacb5efd8ea6
 DIST libmateweather-1.14.3.tar.xz 3345244 SHA256 21507911543bccdaec57541b030de0d5522ef9640b1ac24044223bb43d026266 SHA512 51e1a29b5faca6d433f6a84fc3e08bf39e87ac48d77ff90085cd7d394b3f31388f7b6b3382e4b75dbdf3b2d07f16e9f9f92bff713d3a038270314313f614af36 WHIRLPOOL d87ce7627e1b0427ad8b2ae0fd997e77ce8caead61f5f930f5b925d0366c7efa27d48ff881dfb670f27de46de6379583fa7ea548ed159b34d541a92cde95e889
+DIST libmateweather-1.16.1.tar.xz 3346620 SHA256 a3569ea5a51ec75eb29aadfba253faf04fbd3815d0a7882ddf6bd6c9c2422b70 SHA512 7cc49cc3fc16a3f06cd50db49f868d8f31a2acc95cf0c6912724248a1b35700ae0600363cd891d5bdf9961d3ae373841a0df412382933084f5e5224ff21aa386 WHIRLPOOL 5269293f740a1c8ef9d30351278514c52569e437ba1d231480b77cf42ae64ec738c22e9336275f5a8908ed86479690d53d6001b420832180b3cc634bfb37b803
diff --git a/dev-libs/libmateweather/libmateweather-1.16.1.ebuild b/dev-libs/libmateweather/libmateweather-1.16.1.ebuild
new file mode 100644 (file)
index 0000000..19ba7a2
--- /dev/null
@@ -0,0 +1,70 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 mate
+
+if [[ ${PV} != 9999 ]]; then
+       KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="MATE library to access weather information from online services"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="debug gtk3 python"
+
+REQUIRED_USE="
+       gtk3? ( !python )
+       python? ( ${PYTHON_REQUIRED_USE} )
+       "
+
+COMMON_DEPEND=">=dev-libs/glib-2.36:2[${PYTHON_USEDEP}]
+       >=dev-libs/libxml2-2.6:2
+       >=net-libs/libsoup-2.34:2.4
+       >=sys-libs/timezone-data-2010k:0
+       x11-libs/gdk-pixbuf:2
+       virtual/libintl:0
+       !gtk3? ( >=x11-libs/gtk+-2.24:2 )
+       gtk3? ( >=x11-libs/gtk+-3.0:3 )
+       python? (
+               ${PYTHON_DEPS}
+               >=dev-python/pygobject-2:2[${PYTHON_USEDEP}]
+               >=dev-python/pygtk-2:2[${PYTHON_USEDEP}]
+       )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+       dev-util/gtk-doc
+       dev-util/gtk-doc-am
+       >=dev-util/intltool-0.50.1:*
+       sys-devel/gettext:*
+       >=sys-devel/libtool-2.2.6:2
+       virtual/pkgconfig:*"
+
+src_prepare() {
+       mate_src_prepare
+       use python && python_copy_sources
+}
+
+src_configure() {
+       mate_py_cond_func_wrap mate_src_configure \
+               --enable-locations-compression \
+               --disable-all-translations-in-one-xml \
+               --with-gtk=$(usex gtk3 3.0 2.0) \
+               $(use_enable python)
+}
+
+src_compile() {
+       mate_py_cond_func_wrap default
+}
+
+src_install() {
+       mate_py_cond_func_wrap mate_src_install
+}