sys-kernel/git-sources: Automated version bump to 5.2_rc2.
authorAgostino Sarubbo <ago@gentoo.org>
Mon, 27 May 2019 08:13:30 +0000 (10:13 +0200)
committerAgostino Sarubbo <ago@gentoo.org>
Mon, 27 May 2019 08:13:30 +0000 (10:13 +0200)
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

sys-kernel/git-sources/Manifest
sys-kernel/git-sources/git-sources-5.2_rc2.ebuild [new file with mode: 0644]

index 23d7c9c3e02d72676b0708b8418b0fb7dc2e34b0..18d89fb14bbaa351b7d7742ac52e861700df6192 100644 (file)
@@ -8,3 +8,4 @@ DIST patch-5.1-rc5.patch 40391650 BLAKE2B 3f6d76f528e9eed9611315362e1c78821968c2
 DIST patch-5.1-rc6.patch 40668793 BLAKE2B 5228d2bd81642b28247ef39d021c3baee9cb9f396aa09798574fa4d928815016f02578dc886777ae1c69a746032d2a86cc25655ae0a80f2fc0805a2b61454edc SHA512 cb134cef2d9cbad89a30cea29363059c6681a796e66347c350f08f1a2399442700e423b3f693a1cbdf573f147ae8251624b80cbb90cb787c35f8b4b688385eba
 DIST patch-5.1-rc7.patch 40788333 BLAKE2B c77b212fed9949610426839d7d9bdd616457bcba5d37b2df47c1552eb00bcaf97c843464748791f73e8ce7979a4e97382d639f8ca79babf92c20c473c361ec48 SHA512 0e60f9d6097d4404691f23d74a9e519af495da1f9d94d262739f841f3d2bd8f1c68d8c2f113a8622904e65c56ac5d069aa7984315f8790b2118601764600e8ce
 DIST patch-5.2-rc1.patch 46729627 BLAKE2B e6096414073f46d0bd9ec3a8f0f2594344ebea66d0f803902175bf37c82cdc68c32b9c4bb45515be8bbed4ae82fad90319b304cbf849c9ca75f9aa6c390c7d87 SHA512 12cb66e4680b0fc74fb22c9f4a02905b8feae724be7c51dc69725aeb839c817d964537193b5738d85fd4ee4d8544be2864a33814f4b64d1468dc0b17a05a40e9
+DIST patch-5.2-rc2.patch 49912438 BLAKE2B 38140ffd6b0d62b43fc0d657e28a384d2887cc1f961c10d631dc4b2826c8ec82e6db947ff0d0e5f3586e115eb4f976231aa51bc005786f129ce59dd5c053f8be SHA512 4df97c0911b3fc0c186ef81a204c0633660f9484583fbf76e2c15ed3a60bf31c9caf9cda46232034fcae87ad6ab53bedd52f420b4db446c6c888cd63942fd615
diff --git a/sys-kernel/git-sources/git-sources-5.2_rc2.ebuild b/sys-kernel/git-sources/git-sources-5.2_rc2.ebuild
new file mode 100644 (file)
index 0000000..8509b23
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.1"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+       postinst_sources
+}