sci-geosciences/opencpn-plugin-logbookkonni: bump version
authorMarc Schiffbauer <mschiff@gentoo.org>
Fri, 28 Aug 2015 12:50:56 +0000 (14:50 +0200)
committerMarc Schiffbauer <mschiff@gentoo.org>
Fri, 28 Aug 2015 12:52:26 +0000 (14:52 +0200)
Package-Manager: portage-2.2.20.1

sci-geosciences/opencpn-plugin-logbookkonni/Manifest
sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-1.2018.ebuild [new file with mode: 0644]

index cefb4d5d2f0100f295218c6fd8f4ebd8bb5c90eb..d8e156af78ac2df6e9988ca69e3ddc711777ff5d 100644 (file)
@@ -1 +1,3 @@
 DIST opencpn-plugin-logbookkonni-1.2012.tar.gz 4222736 SHA256 990b753776940f42cfc616842181f7f1603d3cdaef0c4ec5463f3c0a31f038ff SHA512 b8ec20f97a807dce0f62ad4f93d083f03606499f81d8828d57d8b967d69a5b51f1c29319288a66bacb218b6adeae029b3557f50080ed29ed07324e2eac8e9da7 WHIRLPOOL cd716e8d037ad9518913fe48ff19538f361b46e23b9f7df8c7f4e5b07847c93a86ed48926502aa67781e1fc307e98c200e7f4ab6ecf9269947352a4bffec8780
+DIST opencpn-plugin-logbookkonni-1.2018.tar.gz 3768720 SHA256 aa7967cf2a7993968f8842b9adf220a57b065afd4be3899cca0771d780697792 SHA512 5435b639bc635b5bbe87c92306d93dee7897ce3e5c6bb383aa228ad90127d2ab1f2a5e871a68abfec30ff2a327c4c21c023a61ccdad445a25bbb8a44fec19d41 WHIRLPOOL ed6bd46ca2b7dd637f0da7bcfd1c6457f10cd2b0cb9a00bf6babd05271ada7b31d23360a5f57ffccdd9d1d49dfbf135dea2c5413fd219d30a0d4d175b3f5f823
+DIST opencpn-plugin-logbookkonni-1.2018_Layouts.zip 1722887 SHA256 9b31cbf893069ba7037a7eca569a46e52b773439f44eedb7f4202b908817d48e SHA512 5ce35b3f4c14a432b472db496e8a5dc46fbcd5b0b404c085d6d024f2f383ae9e3767ccdf750177f102ec19a7a0d61a1ab331fef701bf29f8c851305a73923296 WHIRLPOOL bb4f49322f27b7fe0804cf035ddcb87fcca6ade5b968ce703f74f7498e58fc8146ab20839a7525f92ce92fc5151b75a45fcddf54e99c202baa8711f89e91ffb2
diff --git a/sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-1.2018.ebuild b/sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-1.2018.ebuild
new file mode 100644 (file)
index 0000000..ea75b60
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+inherit cmake-utils wxwidgets
+
+MY_PN="LogbookKonni-1.2"
+
+DESCRIPTION="Logbook Plugin for OpenCPN"
+HOMEPAGE="http://opencpn.org/ocpn/downloadplugins"
+SRC_URI="https://github.com/delatbabel/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+       https://github.com/delatbabel/${MY_PN}/releases/download/v${PV}/LogbookKonni_Layouts.zip -> ${P}_Layouts.zip
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=sci-geosciences/opencpn-4.0.0
+       sys-devel/gettext
+"
+DEPEND="
+       app-arch/zip
+       ${RDEPEND}
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+       # install layouts as zip
+       cmake-utils_src_install
+       cd "$WORKDIR"
+       zip -r "$D"/usr/share/opencpn/plugins/logbookkonni_pi/data/LogbookKonni_Layouts.zip Clouds HTMLLayouts ODTLayouts
+}
+
+pkg_postinst() {
+       elog "Installation of logbook layouts"
+       elog "*******************************"
+       elog ""
+       elog "The default layouts zip file has been installed to:"
+       elog "/usr/share/opencpn/plugins/logbookkonni_pi/data/LogbookKonni_Layouts.zip"
+       elog ""
+       elog "After starting OpenCPN, go to Options->Plugins->Logbook->Settings,"
+       elog "click the install button and choose the above mentioned zip file"
+       elog ""
+}