patch to fix the location of the include directive for config.h. submitted upstream...
authorSeemant Kulleen <seemant@gentoo.org>
Mon, 19 Jun 2006 17:31:04 +0000 (17:31 +0000)
committerSeemant Kulleen <seemant@gentoo.org>
Mon, 19 Jun 2006 17:31:04 +0000 (17:31 +0000)
Package-Manager: portage-2.1

media-libs/libdc1394/ChangeLog
media-libs/libdc1394/files/digest-libdc1394-2.0.0_pre7-r1 [new file with mode: 0644]
media-libs/libdc1394/files/libdc1394-2.0.0_pre7-config.h-include-fix.patch [new file with mode: 0644]
media-libs/libdc1394/libdc1394-2.0.0_pre7-r1.ebuild [new file with mode: 0644]

index 31d2b8b550f66b9ed1cd78020c05823aaac3494c..5181d3fb26c4f34d7a5caf53f2c90688c647d66d 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for media-libs/libdc1394
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdc1394/ChangeLog,v 1.22 2006/06/08 20:02:59 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdc1394/ChangeLog,v 1.23 2006/06/19 17:31:04 seemant Exp $
+
+*libdc1394-2.0.0_pre7-r1 (19 Jun 2006)
+
+  19 Jun 2006; Seemant Kulleen <seemant@gentoo.org>
+  +files/libdc1394-2.0.0_pre7-config.h-include-fix.patch,
+  +libdc1394-2.0.0_pre7-r1.ebuild:
+  patch to fix the location of the include directive for config.h. submitted
+  upstream as well
 
 *libdc1394-2.0.0_pre7 (08 Jun 2006)
 
diff --git a/media-libs/libdc1394/files/digest-libdc1394-2.0.0_pre7-r1 b/media-libs/libdc1394/files/digest-libdc1394-2.0.0_pre7-r1
new file mode 100644 (file)
index 0000000..724bf2b
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 b826164d91c4c8dae668cb138cd75b01 libdc1394-2.0.0-pre7.tar.gz 410416
+RMD160 529527ba2c91d4567477d8e32b5975d0c9f49c77 libdc1394-2.0.0-pre7.tar.gz 410416
+SHA256 a737f0cdc2e0d77e829cac61b12bbea2ad00f65a637c09ec9c2189fb2938fe41 libdc1394-2.0.0-pre7.tar.gz 410416
diff --git a/media-libs/libdc1394/files/libdc1394-2.0.0_pre7-config.h-include-fix.patch b/media-libs/libdc1394/files/libdc1394-2.0.0_pre7-config.h-include-fix.patch
new file mode 100644 (file)
index 0000000..0a4a6a2
--- /dev/null
@@ -0,0 +1,22 @@
+diff -urN libdc1394-2.0.0-pre7.orig/libdc1394/dc1394_vendor_avt.c libdc1394-2.0.0-pre7/libdc1394/dc1394_vendor_avt.c
+--- libdc1394-2.0.0-pre7.orig/libdc1394/dc1394_vendor_avt.c    2006-06-19 13:19:06.522104015 -0400
++++ libdc1394-2.0.0-pre7/libdc1394/dc1394_vendor_avt.c 2006-06-19 13:19:20.670991015 -0400
+@@ -22,6 +22,7 @@
+  */
+ #include "dc1394_vendor_avt.h"
++#include "config.h"
+ /********************************************************/
+ /* Configuration Register Offsets for Advances features */
+diff -urN libdc1394-2.0.0-pre7.orig/libdc1394/dc1394_vendor_avt.h libdc1394-2.0.0-pre7/libdc1394/dc1394_vendor_avt.h
+--- libdc1394-2.0.0-pre7.orig/libdc1394/dc1394_vendor_avt.h    2006-06-19 13:18:55.533415118 -0400
++++ libdc1394-2.0.0-pre7/libdc1394/dc1394_vendor_avt.h 2006-06-19 13:19:14.342594287 -0400
+@@ -26,7 +26,6 @@
+ #include <libraw1394/raw1394.h>
+ #include "dc1394_control.h"
+ #include "dc1394_register.h"
+-#include "config.h"
+ typedef struct __dc1394_avt_adv_feature_info_struct 
+ {
diff --git a/media-libs/libdc1394/libdc1394-2.0.0_pre7-r1.ebuild b/media-libs/libdc1394/libdc1394-2.0.0_pre7-r1.ebuild
new file mode 100644 (file)
index 0000000..459d402
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdc1394/libdc1394-2.0.0_pre7-r1.ebuild,v 1.1 2006/06/19 17:31:04 seemant Exp $
+
+inherit eutils
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="library for controling IEEE 1394 conforming based cameras"
+HOMEPAGE="http://sourceforge.net/projects/libdc1394/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X"
+
+RDEPEND=">=sys-libs/libraw1394-1.2.0
+               X? ( || ( ( x11-libs/libSM x11-libs/libXv )
+                                 virtual/x11 ) )"
+DEPEND="!=sys-libs/libdc1394-2*
+       ${RDEPEND}
+       sys-devel/libtool"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+       epatch ${FILESDIR}/${P}-config.h-include-fix.patch
+}
+
+src_compile() {
+       econf \
+               --program-suffix=2 \
+               $(use_with X x) || die
+       emake || die "emake failed"
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die
+       dodoc NEWS README AUTHORS ChangeLog
+}