app-office/libreoffice: Fix build with poppler-0.86.0
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 5 Apr 2020 16:12:49 +0000 (18:12 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 5 Apr 2020 17:04:42 +0000 (19:04 +0200)
Closes: https://bugs.gentoo.org/711102
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-office/libreoffice/files/libreoffice-6.4.2.2-poppler-0.86.patch [new file with mode: 0644]
app-office/libreoffice/libreoffice-6.4.2.2.ebuild

diff --git a/app-office/libreoffice/files/libreoffice-6.4.2.2-poppler-0.86.patch b/app-office/libreoffice/files/libreoffice-6.4.2.2-poppler-0.86.patch
new file mode 100644 (file)
index 0000000..c56ba89
--- /dev/null
@@ -0,0 +1,15 @@
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+index e9c2a407c279..16ad04bf660a 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+@@ -563,7 +563,9 @@ void PDFOutDev::processLink(Link* link, Catalog*)
+     if (!(pAction && pAction->getKind() == actionURI))
+         return;
+-#if POPPLER_CHECK_VERSION(0, 72, 0)
++#if POPPLER_CHECK_VERSION(0, 86, 0)
++    const char* pURI = static_cast<LinkURI*>(pAction)->getURI().c_str();
++#elif POPPLER_CHECK_VERSION(0, 72, 0)
+     const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->c_str();
+ #else
+     const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->getCString();
index a6f3687b3c41a7e3ec95163d141dd381b7ac36e3..b3b6af835f930ae7ff8640619bf46ad0ef07f05b 100644 (file)
@@ -252,6 +252,9 @@ PATCHES=(
        "${FILESDIR}/${PN}-5.4-system-pyuno.patch"
        "${FILESDIR}/${PN}-5.3.4.2-kioclient5.patch"
        "${FILESDIR}/${PN}-6.1-nomancompress.patch"
+
+       # TODO: upstream (for now taken from Arch Linux)
+       "${FILESDIR}/${P}-poppler-0.86.patch" # bug 711102
 )
 
 S="${WORKDIR}/${PN}-${MY_PV}"