net-analyzer/nmap: Version bump.
authorJeroen Roovers <jer@gentoo.org>
Fri, 30 Sep 2016 09:14:08 +0000 (11:14 +0200)
committerJeroen Roovers <jer@gentoo.org>
Fri, 30 Sep 2016 09:14:08 +0000 (11:14 +0200)
Package-Manager: portage-2.3.1

net-analyzer/nmap/Manifest
net-analyzer/nmap/nmap-7.30.ebuild [new file with mode: 0644]

index 3b2033a7c198065da59389239ef133245a41c745..1a19fab76e8e9adf701d0e8ecebe686103213ac0 100644 (file)
@@ -3,4 +3,5 @@ DIST nmap-7.01.tar.bz2 8922697 SHA256 cf1fcd2643ba2ef52f47acb3c18e52fa12a4ae4b72
 DIST nmap-7.12.tar.bz2 8960599 SHA256 63df082a87c95a189865d37304357405160fc6333addcf5b84204c95e0539b04 SHA512 91156499c6f903fb565fa2b0faa74043d078493312f9489071fafc687301017afc16c7eb26c092f1fa142e78c98a436833f56a9f015cb2a17aa6f6220b6a0b98 WHIRLPOOL ed4f3b00dc5e71f841133026c9b40aa285a9e47c6fd4ee012d235c22c6193039d19256b42708b5e38fe94840d7b4535cc78a4e6681f66a2fed3eb251070d0fde
 DIST nmap-7.25BETA1.tar.bz2 8580974 SHA256 6866457809b598f8e85c9e8c79773f1821de29cc1b6f574cc7fed4ad8c01c178 SHA512 6d2fc83186086ea8d01003b8d79af0b45788378ef32c5e8f9b14561db5adfc407e388df044f1e3420f4f3d21115bc1623da0b6a926bd3d20816265cb10efe092 WHIRLPOOL 18bfca4d494c59fa6625ecb1e5ad7a7f838236c73269c9e0b2094e57d047ba1095284e26d4cbfb1a85a797af4b7f4abf02ffbc89c4664c6a5aea3912d4c3fb94
 DIST nmap-7.25BETA2.tar.bz2 8874592 SHA256 6c66a150c9e346ccdca0aa16ef8c2a5310449444fe15cf5ec3f3a151978378d0 SHA512 0a40267d578ac7ff461783a4b22e584a7c3fee42c321843fce24dd6cddabc068cc7acd0fc8fd85f3952ed05033792adcb28e2919ed70f5fb30826a81c4777fe0 WHIRLPOOL 4c165d45afe0295f5cdb68cd90e7e7d5951ffb31115b3aedc37722872b130adab088cae851c12db0d213aabecfbdcda2b1dae48c6a01bdd8e5d98148c084c98d
+DIST nmap-7.30.tar.bz2 9003761 SHA256 ba38a042ec67e315d903d28a4976b74999da94c646667c0c63f31e587d6d8d0f SHA512 effef6d1d3f333a8c9a628a2acc0d0faec5967ef09a7d831a4d8d287f224167305e54f575e571eebb0f30544675bf27c834fdaf468db00cdb3fcad14e392303c WHIRLPOOL d20627c806131fcec6583f8d2eb3504f669d2165391d5ba17bdf86be3417cc5ca783ff5d1552735bbeb75ac34d236ca36cfe754c29596ec8703a6b669a91aa55
 DIST nmap-logo-64.png 3289 SHA256 4c72ff1eeffeeaa1039b251d9f2d675936e65db686fe3b57a35c2183ce67a8aa SHA512 fb102d12aaeebc8a97543ecd653a3606e86996ad679bc26d6e6e274ad05ec3e9f92521289d1a24153c521b699e8c0cfa65d8856bb49af53ee4837268bbc6b5d3 WHIRLPOOL 6093aadcb9880587e17d39d45fcbe57bb62777f220655e6ed5b5f900ce49cb8c5a53e24d7db0de6f8909eb0f8981f7565e6ae9b9bf9283a4ccccb0526eab5313
diff --git a/net-analyzer/nmap/nmap-7.30.ebuild b/net-analyzer/nmap/nmap-7.30.ebuild
new file mode 100644 (file)
index 0000000..1fe61b5
--- /dev/null
@@ -0,0 +1,172 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite,xml"
+inherit autotools eutils flag-o-matic python-single-r1 toolchain-funcs
+
+MY_P=${P/_beta/BETA}
+
+DESCRIPTION="A utility for network discovery and security auditing"
+HOMEPAGE="http://nmap.org/"
+SRC_URI="
+       http://nmap.org/dist/${MY_P}.tar.bz2
+       https://dev.gentoo.org/~jer/nmap-logo-64.png
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+IUSE="ipv6 libressl +nse system-lua ncat ndiff nls nmap-update nping ssl zenmap"
+NMAP_LINGUAS=( de fr hi hr it ja pl pt_BR ru zh )
+IUSE+=" ${NMAP_LINGUAS[@]/#/linguas_}"
+
+REQUIRED_USE="
+       system-lua? ( nse )
+       ndiff? ( ${PYTHON_REQUIRED_USE} )
+       zenmap? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+       dev-libs/liblinear:=
+       dev-libs/libpcre
+       || ( >=net-libs/libpcap-1.8.0 <net-libs/libpcap-1.8.0[ipv6?] )
+       zenmap? (
+               dev-python/pygtk:2[${PYTHON_USEDEP}]
+               ${PYTHON_DEPS}
+       )
+       system-lua? ( >=dev-lang/lua-5.2[deprecated] )
+       ndiff? ( ${PYTHON_DEPS} )
+       nls? ( virtual/libintl )
+       nmap-update? ( dev-libs/apr dev-vcs/subversion )
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:= )
+       )
+"
+DEPEND="
+       ${RDEPEND}
+       nls? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+       if use ndiff || use zenmap; then
+               python-single-r1_pkg_setup
+       fi
+}
+
+src_unpack() {
+       # prevent unpacking the logo
+       unpack ${MY_P}.tar.bz2
+}
+
+src_prepare() {
+       epatch \
+               "${FILESDIR}"/${PN}-5.10_beta1-string.patch \
+               "${FILESDIR}"/${PN}-5.21-python.patch \
+               "${FILESDIR}"/${PN}-6.46-uninstaller.patch \
+               "${FILESDIR}"/${PN}-6.47-no-libnl.patch \
+               "${FILESDIR}"/${PN}-6.25-liblua-ar.patch \
+               "${FILESDIR}"/${PN}-7.25-no-FORTIFY_SOURCE.patch \
+               "${FILESDIR}"/${PN}-7.25-CXXFLAGS.patch \
+               "${FILESDIR}"/${PN}-7.25-libpcre.patch
+
+       if use nls; then
+               local lingua=''
+               for lingua in ${NMAP_LINGUAS[@]}; do
+                       if ! use linguas_${lingua}; then
+                               rm -r zenmap/share/zenmap/locale/${lingua} || die
+                               rm zenmap/share/zenmap/locale/${lingua}.po || die
+                       fi
+               done
+       else
+               # configure/make ignores --disable-nls
+               for lingua in ${NMAP_LINGUAS[@]}; do
+                       rm -r zenmap/share/zenmap/locale/${lingua} || die
+                       rm zenmap/share/zenmap/locale/${lingua}.po || die
+               done
+       fi
+
+       sed -i \
+               -e '/^ALL_LINGUAS =/{s|$| id|g;s|jp|ja|g}' \
+               Makefile.in || die
+
+       sed -i \
+               -e '/rm -f $@/d' \
+               $(find . -name Makefile.in) \
+               || die
+
+       # Fix desktop files wrt bug #432714
+       sed -i \
+               -e '/^Encoding/d' \
+               -e 's|^Categories=.*|Categories=Network;System;Security;|g' \
+               zenmap/install_scripts/unix/zenmap-root.desktop \
+               zenmap/install_scripts/unix/zenmap.desktop || die
+
+       epatch_user
+
+       eautoreconf
+}
+
+src_configure() {
+       # The bundled libdnet is incompatible with the version available in the
+       # tree, so we cannot use the system library here.
+       econf \
+               $(use_enable ipv6) \
+               $(use_enable nls) \
+               $(use_with zenmap) \
+               $(usex nse --with-liblua=$(usex system-lua /usr included '' '') --without-liblua) \
+               $(use_with ncat) \
+               $(use_with ndiff) \
+               $(use_with nmap-update) \
+               $(use_with nping) \
+               $(use_with ssl openssl) \
+               --with-libdnet=included \
+               --with-pcre=/usr
+       #       --with-liblinear=/usr \
+       #       Commented because configure does weird things, while autodetection works
+}
+
+src_compile() {
+       local directory
+       for directory in . libnetutil nsock/src \
+               $(usex ncat ncat '') \
+               $(usex nmap-update nmap-update '') \
+               $(usex nping nping '')
+       do
+               emake -C "${directory}" makefile.dep
+       done
+
+       emake \
+               AR=$(tc-getAR) \
+               RANLIB=$(tc-getRANLIB)
+}
+
+src_install() {
+       LC_ALL=C emake -j1 \
+               DESTDIR="${D}" \
+               STRIP=: \
+               nmapdatadir="${EPREFIX}"/usr/share/nmap \
+               install
+       if use nmap-update;then
+               LC_ALL=C emake -j1 \
+                       -C nmap-update \
+                       DESTDIR="${D}" \
+                       STRIP=: \
+                       nmapdatadir="${EPREFIX}"/usr/share/nmap \
+                       install
+       fi
+
+       dodoc CHANGELOG HACKING docs/README docs/*.txt
+
+       if use zenmap; then
+               doicon "${DISTDIR}/nmap-logo-64.png"
+               python_optimize
+       fi
+}