dev-python/jsonpickle: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:12:05 +0000 (13:12 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:12:05 +0000 (13:12 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/jsonpickle/Manifest
dev-python/jsonpickle/jsonpickle-1.2.ebuild [deleted file]

index 70ab6e0495f76a7d69b73643f27b0acc8a950146..ed9e81bb4143cb137fc36f417a2601b579e29387 100644 (file)
@@ -1,3 +1,2 @@
-DIST jsonpickle-1.2.tar.gz 74693 BLAKE2B 65f9c18b8693351995f84815d27f2d86ab65fe7a620cda0d346b88db56de45ff6aa21b7ae941e8820e16e184d9a5ac55d56caf112f3930083e63b50751fe2dd8 SHA512 0a5bfb2e77175c9174ee1783301c613e25fcfa60f07e610206d1e1e34053e90b21b12bc1b1045dd03ff2d4efe5940d85d852800037ca01397994c022f0ffb2c6
 DIST jsonpickle-1.3.tar.gz 76571 BLAKE2B 797ac90d1aacb620d9917bd2a34dbc960739b29f64d7bc003c934333fc0d836657a4907a965725248b2f9489876ae251440eab3888112f158c28f19e33efe036 SHA512 5e7faa32f4fd2da88d9cfea8c0355121ece12aa1b4434845e6bd679718f433e5c27835b405f833a31d69d09d7a6ae6c3d5e4bf1f6dc9c50c7ff1690cf82271b0
 DIST jsonpickle-1.4.1.tar.gz 104564 BLAKE2B a3ad6f9c712f39153186b6ccdef515581012ad4ba1251dcb094074f2093eb4b158b9357bdf2e8668073cb21dc3bf6dd2fc3a0058c8597252c558a797432068b9 SHA512 ed6bf3472c59ba907a973c5c6f05de13dbfc75eef103796b8f8a63d388f769527f22667ca8761092d1649ff2caf5a73de0593e370df3e7fcabe06e73b265da35
diff --git a/dev-python/jsonpickle/jsonpickle-1.2.ebuild b/dev-python/jsonpickle/jsonpickle-1.2.ebuild
deleted file mode 100644 (file)
index f27e26f..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
-HOMEPAGE="https://github.com/jsonpickle/jsonpickle/ https://pypi.org/project/jsonpickle/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-# There are optional json backends serializer/deserializers in addition to those selected here
-# jsonlib, yajl.
-RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
-               dev-python/feedparser[${PYTHON_USEDEP}]
-               dev-python/ujson[${PYTHON_USEDEP}]
-               "
-DEPEND="test? ( ${RDEPEND} )
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # Prevent un-needed d'loading during doc build
-       sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && { python_setup python2_7 && sphinx-build -b html -c docs/source/ docs/source/ docs/source/html || die; }
-}
-
-python_test() {
-       # An apparent regression in tests
-       # https://github.com/jsonpickle/jsonpickle/issues/124
-       einfo "testsuite has optional tests for package demjson"
-       ${PYTHON} tests/runtests.py || die
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/source/html/. )
-       distutils-r1_python_install_all
-}