dev-python/click-log: apply distutils_enable_tests, add py37 compat
authorWim Muskee <wimmuskee@gmail.com>
Sun, 8 Dec 2019 12:45:29 +0000 (13:45 +0100)
committerAaron Bauman <bman@gentoo.org>
Fri, 13 Dec 2019 16:07:42 +0000 (11:07 -0500)
Signed-off-by: Wim Muskee <wimmuskee@gmail.com>
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-python/click-log/click-log-0.1.8.ebuild
dev-python/click-log/click-log-0.2.1.ebuild
dev-python/click-log/click-log-0.3.2.ebuild

index 892e37863876273bf9a7fd4259d9b69b6e9336fe..0a7775893540e62cfefc1d84753bb4bb08aa732d 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
 
 inherit distutils-r1
 
@@ -13,15 +13,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
 RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
 
 DOCS=( README.rst )
 
-python_test() {
-       py.test -v || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest
index 892e37863876273bf9a7fd4259d9b69b6e9336fe..0a7775893540e62cfefc1d84753bb4bb08aa732d 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
 
 inherit distutils-r1
 
@@ -13,15 +13,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
 RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
 
 DOCS=( README.rst )
 
-python_test() {
-       py.test -v || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest
index 9568fa319e0964fa95b1e2eff29e976eda186a2a..7d9bc6d73ff9c5dd49443c094a49d741ad7a06e4 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
 
 inherit distutils-r1
 
@@ -13,15 +13,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
 RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
 
 DOCS=( README.rst )
 
-python_test() {
-       py.test -v || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest