dev-python/lunr: A Python implementation of Lunr.js
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Sat, 28 Mar 2020 14:07:45 +0000 (15:07 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 9 Apr 2020 12:37:41 +0000 (15:37 +0300)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/lunr/Manifest [new file with mode: 0644]
dev-python/lunr/lunr-0.5.6.ebuild [new file with mode: 0644]
dev-python/lunr/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/lunr/Manifest b/dev-python/lunr/Manifest
new file mode 100644 (file)
index 0000000..61568bf
--- /dev/null
@@ -0,0 +1 @@
+DIST lunr-0.5.6.tar.gz 43815 BLAKE2B 0d68dc098a71c1fdaaddee80605fc63a0d30492b6e329cd8f963dc740bc40fc79959bf20b159af6b88c4eb2736db6793c6fea5b74968f74923741f220a372a89 SHA512 48167c90ac1351fd3aeaefbead752d8b96b941e79edb33a4232ac588a2fa54775972c883564ea23e3d58f3f5a94ee448c27049f4410016032f5a8f36aa4c6709
diff --git a/dev-python/lunr/lunr-0.5.6.ebuild b/dev-python/lunr/lunr-0.5.6.ebuild
new file mode 100644 (file)
index 0000000..09cb1c5
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python implementation of Lunr.js"
+HOMEPAGE="https://github.com/yeraydiazdiaz/lunr.py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-python/future[${PYTHON_USEDEP}]
+       dev-python/nltk[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? (
+       dev-python/mock[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+       # No such file or directory: '/var/tmp/portage/dev-python/lunr-0.5.6/work/lunr-0.5.6/tests/fixtures/stemming_vocab.json'
+       # file missing in pypi release tarball
+       sed -i -e 's:test_reduces_words_to_their_stem:_&:' tests/test_stemmer.py || die
+
+       distutils-r1_python_prepare_all
+}
diff --git a/dev-python/lunr/metadata.xml b/dev-python/lunr/metadata.xml
new file mode 100644 (file)
index 0000000..5a0914d
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>andrewammerlaan@riseup.net</email>
+               <name>Andrew Ammerlaan</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">lepture/python-livereload</remote-id>
+       </upstream>
+</pkgmetadata>