dev-db/mariadb: Add -Wl,--no-relax to fix build on alpha
authorMatt Turner <mattst88@gentoo.org>
Thu, 19 Mar 2020 03:35:00 +0000 (20:35 -0700)
committerMatt Turner <mattst88@gentoo.org>
Thu, 19 Mar 2020 03:47:00 +0000 (20:47 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-db/mariadb/mariadb-10.4.12.ebuild

index 0e5f5ec5df15f2e6a37b33c4b99719b47df3fe8c..b355f9f094863d283abd8ca338877660fc00b03e 100644 (file)
@@ -325,6 +325,9 @@ src_configure() {
        # Bug #114895, bug #110149
        filter-flags "-O" "-O[01]"
 
+       # It fails on alpha without this
+       use alpha && append-ldflags "-Wl,--no-relax"
+
        append-cxxflags -felide-constructors
 
        # bug #283926, with GCC4.4, this is required to get correct behavior.