xfce-extra/xfce4-linelight-plugin: remove last rited package
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 11 May 2019 17:04:40 +0000 (20:04 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 11 May 2019 17:04:40 +0000 (20:04 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
xfce-extra/xfce4-linelight-plugin/Manifest [deleted file]
xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.7-port-to-xfcerc.patch [deleted file]
xfce-extra/xfce4-linelight-plugin/metadata.xml [deleted file]
xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7-r1.ebuild [deleted file]

diff --git a/xfce-extra/xfce4-linelight-plugin/Manifest b/xfce-extra/xfce4-linelight-plugin/Manifest
deleted file mode 100644 (file)
index acffbc2..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST xfce4-linelight-plugin_0.1.7.orig.tar.bz2 239068 BLAKE2B 26a279756db47f7e53d57e83642739b4c726462f2184cd6d1f23b6e80b11fd56995003a0c50d1203c64d80b5ea9b56430741278de9bc6064b1d96edcf0b3c5f1 SHA512 56cca14813ed75d008821db6c112fb213930658d78ae2ad0eeaeb0816272df35fa9c962ea9ab0a41d082f4f4dcc8dbbcd9fb70b847a8044ade0e57d96b056737
diff --git a/xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.7-port-to-xfcerc.patch b/xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.7-port-to-xfcerc.patch
deleted file mode 100644 (file)
index 2c7bb47..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-http://bugs.gentoo.org/411949
-http://bugs.ganymede.ch/
-http://lionel.lefolgoc.net/misc/01_port-to-xfcerc.patch
-
---- panel-plugin/linelight.c
-+++ panel-plugin/linelight.c
-@@ -207,7 +207,7 @@ void linelight_add_list_entry(LineLightD
-     remove_newline(entry);
-     GtkTreeIter iter;
--    char *icon;
-+    const gchar *icon = NULL;
-     GdkPixbuf *pixbuf;
-     gtk_list_store_insert(data->list, &iter, data->listPointer[sec]);
-@@ -218,13 +218,15 @@ void linelight_add_list_entry(LineLightD
-     //icon
-     if (g_file_query_exists (file, NULL) && sec == BIN_SECTION )
-     {
--        XfceDesktopEntry* app = xfce_desktop_entry_new(entry,categories,3);
-+        XfceRc* app = xfce_rc_simple_open(entry, TRUE);
--        if (app != NULL && xfce_desktop_entry_get_string(app, "Icon", TRUE, &icon)  && NULL != (pixbuf= load_icon(icon)))
-+        if (app != NULL)
-         {
--            gtk_list_store_set(data->list, &iter, ICON_COL, pixbuf, -1);
--            g_object_unref(app);
--            free(icon);
-+            xfce_rc_set_group(app, G_KEY_FILE_DESKTOP_GROUP);
-+            icon = xfce_rc_read_entry(app, G_KEY_FILE_DESKTOP_KEY_ICON, NULL);
-+            if (icon != NULL && NULL != (pixbuf= load_icon(icon)))
-+                gtk_list_store_set(data->list, &iter, ICON_COL, pixbuf, -1);
-+            xfce_rc_close(app);
-         }
-     }
-     else if (file != NULL)
---- panel-plugin/main.c
-+++ panel-plugin/main.c
-@@ -155,14 +155,15 @@ static void cell_renderer(GtkTreeViewCol
-     }
-     else if (strstr(name,".desktop") != NULL) //Application names based on .desktop files
-     {
--        XfceDesktopEntry *application = xfce_desktop_entry_new(path,categories,3);
--        if (XFCE_IS_DESKTOP_ENTRY(application))
-+        XfceRc *application = xfce_rc_simple_open(path, TRUE);
-+        if (application != NULL)
-         {
--            char* app_name;
--            xfce_desktop_entry_get_string(application, "Name", TRUE, &app_name);
--            g_object_unref(application);
--            g_object_set(cell,"text", app_name,NULL);
--            free(app_name);
-+            const gchar* app_name = NULL;
-+            xfce_rc_set_group(application, G_KEY_FILE_DESKTOP_GROUP);
-+            app_name = xfce_rc_read_entry(application, G_KEY_FILE_DESKTOP_KEY_NAME, NULL);
-+            if (app_name != NULL)
-+                g_object_set(cell,"text", app_name, NULL);
-+            xfce_rc_close(application);
-         }
-     }
-     else
diff --git a/xfce-extra/xfce4-linelight-plugin/metadata.xml b/xfce-extra/xfce4-linelight-plugin/metadata.xml
deleted file mode 100644 (file)
index 359901b..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-  <maintainer type="project">
-    <email>xfce@gentoo.org</email>
-    <name>XFCE Team</name>
-  </maintainer>
-</pkgmetadata>
diff --git a/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7-r1.ebuild b/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7-r1.ebuild
deleted file mode 100644 (file)
index 630aa5a..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools multilib
-
-DESCRIPTION="A simple locate based search plug-in for the Xfce panel"
-HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-linelight-plugin"
-SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.bz2"
-#SRC_URI="http://svn.ganymede.ch/private/trunk/${PN}/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE=""
-
-COMMON_DEPEND=">=dev-libs/glib-2.18:2
-       >=x11-libs/gtk+-2.12:2
-       >=xfce-base/xfce4-panel-4.8
-       >=xfce-base/libxfcegui4-4.8"
-RDEPEND="${COMMON_DEPEND}
-       sys-apps/mlocate"
-DEPEND="${COMMON_DEPEND}
-       virtual/pkgconfig
-       sys-devel/gettext"
-
-src_prepare() {
-       eapply -p0 "${FILESDIR}"/${P}-port-to-xfcerc.patch
-       AT_M4DIR=${EPREFIX}/usr/share/xfce4/dev-tools/m4macros eautoreconf
-       default
-}
-
-src_configure() {
-       econf --libexecdir="${EPREFIX}"/usr/$(get_libdir)
-}